Notice: add_custom_background is deprecated since version 3.4! Use add_theme_support

  • ABCDiamond

    #9340

    Hello. I just upgrade both the Graphene Theme and WordPress (to WP 4.0) and now get this message at the top of my website:

    Notice: add_custom_background is deprecated since version 3.4! Use add_theme_support( ‘custom-background’, $args ) instead. in /xxxxxxxxxxxxxxxxxxxx/abcdiamond.co.uk/wp-includes/functions.php on line 3201

    Any ideas for an easy fix ?

    It appears on my admin side AND on my website to all viewers.

    Thanks

    Mod

    Kenneth John Odle

    #43420
    Quote:
    AND on my website to all viewers

    It’s not appearing to me. It appears to you because you are logged in.

    This issue was fixed in Graphene 1.7.3. You can view that in the changelog:

    https://forum.graphene-theme.com/graphene-theme/changelog/

    You have either tinkered with theme files or you have an incomplete install. (Weird, but it sometimes happens.)

    Try reinstalling a fresh copy of Graphene.

    ABCDiamond

    #43421

    I’ve upgraded another of my sites today, to WP4.0, and that one does NOT have the same problem.

    So I guess it must be a theme file change in some way, although that first one is a very basic install. I will try to do a WP update and a Theme re-install again, just in case it went wrong.

    Mod

    Kenneth John Odle

    #43422

    Just reinstalling Graphene should do the trick. WordPress should be okay.

    JCIMB

    #43423

    Getting same error as ABCDiamond is getting.

    Re-installed WordPress 4.0 and Graphene 1.9.3.

    No change.

    Had to rename graphene folder in order to access backend.

    Trying to use a debugger to see where the Notice is coming from.

    Mod

    Kenneth John Odle

    #43424
    Quote:
    Had to rename graphene folder in order to access backend.

    That suggests that you are having other, possible more troublesome problems, than this message appearing.

    ABCDiamond

    #43425

    I re-installed both again, but no change. I just left it for now though. Other sites with the same versions are OK, even on the same host service.

    JCIMB

    #43426

    I am also going to just leave it for now. I turned off Debug in wp-config so I don’t see the Notice.

    The issue with accessing the dashboard seems to be more of a browser issue – it hasn’t happened again so far.

    Thanks Kenneth and ABCDiamond.

    Admin

    Syahir Hakim

    #43427

    We’ll add proper check for WordPress version to fix this issue in the next update.

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.