Not Switching to Desktop

  • Chris

    #7157

    Well I have everything set-up, and everything seems to be working fine. The only problem is that it does not switch to the desktop theme when I click the button.

    I added a widget to the top for the mobile switcher to see if that would help, but that didn’t work either.

    I disabled all plug-ins except Yoast’s SEO and WP-Navi, still no luck.

    On a side note though, the regular graphene-mobile theme did switch like it was supposed to, but the Neo theme doesn’t switch right on my site. The Neo demo site (yours) does switch like it is supposed to, but I don’t know what could be going wrong.

    I’ve tried other browsers too, like Firefox with User Agent detection add-in, but I can’t get it to switch to the desktop version.

    Any suggestions? Thanks.

    The site is http://madeworthy.com

    Admin

    Syahir Hakim

    #37168

    Try going to WP Admin > Settings > Permalink and resave the settings there.

    Check also your .htaccess file for redirect rules, since the server returns the “301 Permanent Redirect” response code when trying to access the URL that switches to desktop theme.

    Chris

    #37169

    Hey,

    I tried resaving the settings by going to the default and then saving them, and then going back to the custom structure, but that didn’t work. I had a problem the other day when I removed W3 Cache, and had to resave the permalink settings then. You think something may be hanging around left over from the W3 plug-in?

    I will disable Yoast’s SEO plugin and do try to resave permalinks and then re-enable that plug-in. I will see what I can come up with.

    Chris

    #37170

    Got it fixed.

    It was caused by an option in Yoast’s plug-in called `Redirect ugly URL’s to clean permalinks.’

    To be fair though, that option in the SEO plug-in does say that it breaks many plug-ins and that if you start having problems, that is the first thing to check.

    I’m good now though. Thanks Again!

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.
Do NOT follow this link or you will be banned from the site!