Non-cropping Pane Images

  • MatthewLang

    #6699

    Since a recent update pane images are being cropped to 340×170.

    There does not appear to be any option around this, and as it crops the featured image, there is no way to control where the crop happens, which can be in exactly the wrong place.

    Please advise how we can either stop the cropping, so the images revert to scaling themselves down they used to, or control the cropping.

    The current example of rebuilding thumbnails works great for consistency, but it doesn’t help when the auto-crop feature focuses on the wrong part of the image.

    serenity.matthew-lang.com

    Admin

    Syahir Hakim

    #33950

    Try using this plugin for more granular control on the image cropping:

    http://wordpress.org/extend/plugins/easy-image-crop/

    MatthewLang

    #33951

    That doesn’t seem to help. The Pane thumnbails are automatically generated and I there aren’t any options to view them on either the front or backend, so I can’t resize them from the edit screen.

    Admin

    Syahir Hakim

    #33952

    Try adding this code to your child theme’s functions.php file:

    <?php
    function my_custom_crop_settings(){
    global $_wp_additional_image_sizes;
    if ( isset( $_wp_additional_image_sizes['graphene-homepage-pane'] ) ){
    $_wp_additional_image_sizes['graphene-homepage-pane']['crop'] = false;
    }
    }
    add_action( 'graphene_setup', 'my_custom_crop_settings' );

    MatthewLang

    #33953

    That plus rebuild thumbails (AJAX) worked in a way. I now have the original thumbnail behaviour back where the Pane thumbnails are proportional, miniatures of the original image.

    Thank you.

    Admin

    Syahir Hakim

    #33954

    Marking thread as resolved. You can do this yourself as well.

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.