No way to add comments

  • Y2Neildotcom

    #5622

    Hello all,

    I have enabled comments in the wordpress discussion settings, the post has the allow comments checkbox marked but when I go to look at the post, there is no option to add a comment.

    Can anyone shed any light on why this might be?

    Many thanks,

    The website in question: Hornets FC

    Prasanna SP

    #32353

    1. Make sure you’ve selected Allow people to post comments on new articles in Discussion Settings.

    2. Go to Graphene Options –> Comments Options –> Commenting and check if you’ve selected Disabled Completely. If it is, then select Use WordPress settings and save changes.

    Y2Neildotcom

    #32354

    I have the Allow people to post comments checked and the graphene options is set to use wordpress settings already.

    I fear maybe I deleted the code to call the comments in the theme’s settings, but its been updated since then so that’d of been overwritten?

    Y2Neildotcom

    #32355

    I’m an idiot. I had this in my child theme stylesheet:

    #comments, #respond{
    display:none;

    I’ve removed it and now it shows. Sorry for wasting your time!!

    The Guy

    #32356

    I recently installed this theme and quite like it. I have had people complain though that they can’t leave comments unless they have a wordpress account. How do I set it up so that both wordpress account holders and non-wordpress account holders can comment?

    I don’t want to lose the possibility for visitors to leave comments yet this theme seems to restrict it.

    Prasanna SP

    #32357

    @The Guy, you were probably selected an option in the discussion settings which allows only logged in users to comment. But I can see the comment form on your site. That means anyone can comment on your site without registering/logging in.

    Since it is a resolved thread, it’s better to create a new topic for your questions.

    The Guy

    #32358

    Thanks for your response Prasanna. I’d already checked the discussion settings and it doesn’t seem to be that causing the problem.

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.