Nav bar and Stack "problem"

  • Gendji

    #10134

    1. I am trying to change the hover and active color of the navigation bar. When i change the CSS under Options -> Display -> Custom CSS, nothing changes. When using a child theme it seems to work.

    .navbar-inverse .navbar-nav > .active > a,
    .navbar-inverse .navbar-nav > .active > a:hover,
    .navbar-inverse .navbar-nav > .active > a:focus,
    .navbar-inverse .navbar-nav > li > a:hover,
    .navbar-inverse .navbar-nav > li > a:hover .desc,
    .navbar-inverse .navbar-nav > .active > a .desc {
    color: #50a063 !important;
    }

    Other customizations however, work using Custom CSS, so why doesn’t this one work?

    2. I am using a static home page. When i leave it blank, the posts options under General -> Front Page work.

    When using Page Builder with Frans Jozef Stack: Posts, those options are disabled somehow. “Disable full-width first blog post” for example, doesn’t work, neither is it an option under the Stacks widget.

    Is there a way to get the options to work with the widget? or how do i disable the full width first blog post when using the widget?

    Admin

    Syahir Hakim

    #45440
    Quote:
    When using a child theme it seems to work.

    This usually means there is a syntax error somewhere in your Custom CSS code. Try pasting the entire code here so that we can take a look.

    Quote:
    When using Page Builder with Frans Jozef Stack: Posts, those options are disabled somehow.

    This is intentional as the options in the available Stacks far exceed the available options in the theme’s options. To disable the full width first blog post in the Posts stack for example, just set the “Lead posts” option to 0.

    Gendji

    #45441

    Custom CSS Code used:

    .carousel .excerpt {
    font: 300 32px/54px 'Open Sans', sans-serif !important;
    font-size: 32px !important;
    font-size: 1.5vw !important;
    line-height: 2.9vw !important;
    }
    .carousel {
    width: 1170px !important;
    max-width: 100% !important;
    margin: 0 auto !important;
    position: relative !important;
    }
    .carousel .slide-title {
    text-transform: uppercase !important;
    font: bold 100px Montserrat, "Open Sans", sans-serif !important;
    font-size: 100px !important;
    font-size: 1.5vw !important;
    }
    .top-bar {
    background: #50a063;
    padding: 10px 0;
    color: #305b3b;
    font-size: 0.9em;
    line-height: normal;
    }
    .top-bar .menu-item a{
    color: #305b3b;
    }
    .top-bar .social-links li a{
    color: #305b3b;
    }
    .top-bar .social-links li a:hover {
    color: #fff;
    }
    .navbar-inverse .navbar-nav > .active > a,
    .navbar-inverse .navbar-nav > .active > a:hover,
    .navbar-inverse .navbar-nav > .active > a:focus,
    .navbar-inverse .navbar-nav > li > a:hover,
    .navbar-inverse .navbar-nav > li > a:hover .desc,
    .navbar-inverse .navbar-nav > .active > a .desc {
    color: #50a063 !important;
    }

    Quote:
    This is intentional as the options in the available Stacks far exceed the available options in the theme’s options. To disable the full width first blog post in the Posts stack for example, just set the “Lead posts” option to 0.

    Ah right, found the option, thanks.

    Admin

    Syahir Hakim

    #45442

    After further investigation, we found a bug with the Custom CSS feature that converts certain symbols (eg. >) into their HTML entities, which breaks the CSS code. We’ve already fixed this and it will be available in the next update.

    In the meantime, you can use a child theme to implement the colour changes above.

    Gendji

    #45443

    Ok, thank you.

    Mod

    Kenneth John Odle

    #45444
    Quote:
    This usually means there is a syntax error somewhere in your Custom CSS code.

    If you do have questions about whether you’ve written valid CSS, you can check for that by using this validator:

    http://jigsaw.w3.org/css-validator/#validate_by_input

    Just copy and paste and then click “Check”. I use this tool a lot.

    Gendji

    #45445

    Thanks, bookmarked the link for future use.

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.