Multilingual posts category problem after updating to 1.8.3

  • nikoska

    #6919

    I have these categories:

    – “Front page GR”, translated to “Front page EN”.

    I use this for displaying posts from this category to my frontpage. When i am in GR lang i see posts from “Front page GR” and when i am in EN lang i see posts from “Front page EN”.

    – “Νέα”, translated to “News”.

    I use this for displaying posts from this category on Slider. When i am in GR lang i see posts from “Νέα” and when i am in EN lang i see posts from “News”.

    Simply and working, until i updated to 1.8.3. After this, when in EN lang i can’t see Frontpage posts from “Front page EN” (frontpage posts in GR lang are displayed correctly).

    If i uncheck this setting on WPML (i use WPML Multilingual CMS Version 2.0.4.1) :

    Setup WPML > Languages > More options > Make themes work multilingual

    1. Adjust IDs for multilingual functionality (This feature turns themes into multilingual, without having to edit their PHP files.)”

    i can see Frontpage posts on GR & EN lang, but i can’t see Slider posts in EN lang (in GR lang Slider posts are displayed correctly).

    I reverted Graphene theme back to 1.8.2 and everything work well again.

    Any ideas?

    (oh, this is my website)

    Admin

    Syahir Hakim

    #36163

    OK, we’ll fix this in the next version. If you know how to checkout from SVN, you can grab the latest development version of the theme from here: https://code.google.com/p/graphene/

    nikoska

    #36164

    I don’t think i am so familiar with this… i don’t even know what you mean “…checkout from SVN” 🙂

    I think i will wait for the next version. Thanks anyway.

    Nikos

    nikoska

    #36165

    I updated to version 1.8.4 but the same problem occurs.

    Admin

    Syahir Hakim

    #36166

    Try turning off the “Make themes work multilingual” option.

    nikoska

    #36167

    I turn it off.

    Now Slider posts is displayed correctly in both languages but when in EN lang i can’t see Frontpage posts from “Front page EN” (frontpage posts in GR lang are displayed correctly).

    I am going to leave it in 1.8.4 version in case it helps to see what i am talking about (http://www.domnista.gr/?lang=en)

    Admin

    Syahir Hakim

    #36168

    I’ve just tested the theme in a multilingual environment, and set up the frontpage to display posts from a specific directory. It’s all working fine as expected on my end, so I’m not sure what’s causing the English posts on your site to not show up on the front page.

    If you have any caching plugin installed in your site, try clearing the plugin’s cache. Also, do the posts that belong to the “Front Page EN” category belongs to the “News” category as well? Try also turning on WP_DEBUG in your wp-config.php and see if any error messages show up.

    nikoska

    #36169

    I will try what you suggest.

    But what it makes it strange to me is that if i turn back to version 1.8.2 everything works well. If i upgrade to 1.8.3 or 1.8.4 the problem shows up.

    nikoska

    #36170

    do the posts that belong to the "Front Page EN" category belongs to the "News" category as well?

    yes they do

    If you have any caching plugin installed in your site, try clearing the plugin's cache

    i don’t think i found any plugin with option like this. Do you suggest to install a plugin for clearing cache?

    Try also turning on WP_DEBUG in your wp-config.php and see if any error messages show up

    i did and many errors showed up. I am not sure what to do. Do you want to give access to my site and take a look? It would very helpful if you had the time.

    Admin

    Syahir Hakim

    #36171
    Quote:
    Quote:
    do the posts that belong to the “Front Page EN” category belongs to the “News” category as well?

    yes they do

    In that case, check the setting for “Exclude the categories from posts listing” option in Graphene Options > Slider Options. It should be set to disabled.

Viewing 10 posts - 1 through 10 (of 16 total)

You must be logged in to reply to this topic.