Mobile Issues

  • Anonymous

    #1486

    Hi. I just installed the mobile theme and it is awesome. However I noticed the following issues:

    – On the Appearance – Graphene Mobile – Post Display Options, checking ‘Hide post author and date’ doesn’t work as expected. Check it and click Save Options then go back and the checkbox is unchecked no matter what.

    – I use Disqus for my comment system and on the mobile theme they appear on top of the default background image, not the light background color. This makes the comment text unreadable due to the non-contrast. On the desktop them, it looks fine.

    The links on the menu appear unorganized. How do I control what appears and how they appear on the mobile theme? On the desktop theme, I have menu that links to some of my categories, on the mobile theme what only shows are the links to pages plus Home. Found the settings in the Appearance – Menu Options

    – Blockquote styling is missing.

    ninoguba

    #15986

    Also adding the following issues to the list as well:

    – Front Page Options is not being applied. I’ve selected “Show Selected Categories” and checked some of my categories but still posts from all categories appear on the front page.

    – How do you control what appears on the mobile “slider”? Does it only show one post or it cycles just like in the desktop theme? It doesn’t appear to be cycling. Can this section be disabled on the mobile theme?

    Thanks.

    ninoguba

    #15987

    The issue about not being compatible with the Disqus comment system you can already ignore. There is a way to customize the background-color style of the Disqus embed.

    But I found another issue on the Front Page Options. It doesn’t follow what you set in the number of posts to show per category.

    Hope you can push out fixes to the mobile theme soon.

    Thanks and keep up the good work!

    Admin

    Syahir Hakim

    #15988

    Hi Nino,

    Thanks for purchasing the theme! I’ll look into the bugs you listed above as soon as possible.

    ninoguba

    #15989

    About the “slider” question I had, I found out that it isn’t actually a similar slider that you have on the desktop theme. I’ve read through your code and realized that it is just whatever post that is first on the list of posts for the frontpage.

    And for my case, its the sticky posts first followed by the rest. But the biggest problem that I see is that it doesn’t follow what category selections and number of posts per category you’ve set to show on the frontpage. Also the order of the stickies seems odd. I think it is listed in chronological order (oldest to newest post). I think it is better if it is listed in reverse order.

    Thanks and hope you can fix this issue. I tried to work through it yesterday but just can’t get it to work as I needed. (I compared it with your code for the Graphene theme to see whether I could reuse some of your code already)

    Admin

    Syahir Hakim

    #15990
    Quote:
    – On the Appearance – Graphene Mobile – Post Display Options, checking ‘Hide post author and date’ doesn’t work as expected. Check it and click Save Options then go back and the checkbox is unchecked no matter what.

    Fixed.

    Quote:
    – Blockquote styling is missing.

    Added.

    Quote:
    About the “slider” question I had, I found out that it isn’t actually a similar slider that you have on the desktop theme. I’ve read through your code and realized that it is just whatever post that is first on the list of posts for the frontpage.

    Yes, there is currently no slider functionality in the mobile theme.

    Quote:
    And for my case, its the sticky posts first followed by the rest. But the biggest problem that I see is that it doesn’t follow what category selections and number of posts per category you’ve set to show on the frontpage.

    There was a bug in the “Show recent posts by category” options. I’ve fixed it and will make it available in the next update.

    Quote:
    Also the order of the stickies seems odd. I think it is listed in chronological order (oldest to newest post). I think it is better if it is listed in reverse order.

    I can’t seem to reproduce this issue. It’s working fine on my end, i.e. newest sticky posts followed by older sticky posts followed by normal posts, all listed in chronological order such that newer posts are displayed first.

    ninoguba

    #15991

    Thanks. Looking forward for the update.

    ninoguba

    #15992

    Regarding the sticky posts order, I believe they are ordered by their last update timestamp instead of their published date. Would be nice if you use their published date for the order so they follow the ordering of the other recent non-sticky posts.

    Thanks.

    Admin

    Syahir Hakim

    #15993
    Quote:
    Regarding the sticky posts order, I believe they are ordered by their last update timestamp instead of their published date. Would be nice if you use their published date for the order so they follow the ordering of the other recent non-sticky posts.

    I still couldn’t reproduce this bug. I just tried updating one of the sticky posts in my dev site for the theme and the sticky posts order still follows the Published timestamp, and not the Updated timestamp.

    In any case, the theme itself doesn’t modify the order in which posts are displayed on the front page. It just uses the WordPress default order, which is chronologically according to the published date in descending order.

    ninoguba

    #15994

    Hmmm. You can see it happening on my site when viewed on a mobile device. If you view it on the desktop it is fine.

    My site: http://hot10.gubster.com

    Thanks

    Admin

    Syahir Hakim

    #15995

    Maybe some plugin interfering with the order? Also, try manually modifying the published date/time of those sticky posts and see if the order changes.

    lizruest

    #15996

    Re: – On the Appearance – Graphene Mobile – Post Display Options, checking ‘Hide post author and date’ doesn’t work as expected. Check it and click Save Options then go back and the checkbox is unchecked no matter what.

    Fixed.


    The checkbox is sticking for me (in Chrome!) but the result is not. I am seeing post author & date. The good news, they’re on the categories I selected! 🙂

    Admin

    Syahir Hakim

    #15997

    OK, this will be fixed soon!

    Admin

    Syahir Hakim

    #15998

    Update: Fixed in version 1.1.3

Viewing 14 posts - 1 through 14 (of 14 total)

You must be logged in to reply to this topic.