misplaced sidebar

  • trailsnet

    #5124

    In the Trailsnet.com website, my sidebar disappeared altogether. A couple days later, it reappeared, but instead of being in the right sidebar location like it’s supposed to be, it is now at the bottom of the content (throughout the entire website including home/blog page and child pages).

    In the general WP press forum, I got some advice to change/replace the sidebar width information in the style sheet.

    I have two problems with this. First, I’m always concerned about changing code on the structure of my website because I am a novice and worry that doing so might completely mess things up and make it hard for me or anyone else to repair later.

    And second, I have no idea where to go to view/edit code on the style sheet.

    Here are some of the suggestions I’ve received. Before I proceed, I want to get some more input from the Graphene experts:

    1.) somehow, the width information for the sidebar might have gone lost;

    try to add this to the bottom of style.css of the child theme:

    .sidebar{width:290px;}

    (or try to upload a new copy of style.css of the theme)

    2.) you put this in ur style sheet line no 1983

    #sidebar1, #sidebar2 {

    display: inline;

    float: left;

    margin-top: 4px;

    padding-bottom: 30px;

    width: 290px; }

    3.) If you scroll all the way down to the bottom of the page, you’ll find the sidebar content. It looks like the category span at the bottom of each post is too wide and is pushing your sidebar content to the bottom. Try changing the width of .category in your style.css

    In addition to being quite helpful, these people sound very knowledgeable. But I don’t want to take any chances, so your input is appreciated.

    Thanks!!

    Mod

    Kenneth John Odle

    #30752

    Moved to Support. Please post in the correct section next time.

    Quote:
    First, I’m always concerned about changing code on the structure of my website because I am a novice and worry that doing so might completely mess things up and make it hard for me or anyone else to repair later.

    Do not edit theme files, because you will lose all of your modifications at the next theme update. Use the theme options or create a child theme.

    Yes, your sidebar is too wide. Try reading this thread:

    https://forum.graphene-theme.com/graphene-support/right-sidebar-moved-to-bottom-of-page

    trailsnet

    #30753

    Thanks for your help on both forums, Kenneth. I’m glad you pointed out the slider option. You’re absolutely right; it makes way more sense than randomly adding code to the css style page.

    Thanks to your great suggestion, I have been able to get the sidebar to show up on my entire site. In order to do that, I had to adjust the container width to 990 px. Now the site is fully functional (my main goal).

    I noticed two small problems that cropped up with this new container width. First, the header image no longer spans the entire width of the header area. Next, I noticed that my Twitter & Facebook icons disappeared from the top of the header.

    For now, these are small prices to pay for having a site that is functioning again, but if you have any suggestions for remedying these two problems, I’d appreciate them. I’ve already tried going into the header display options and also the Header link under Appearance in the Dashboard but couldn’t find a solution in either.

    Either way, you’re a lifesaver and I’m grateful for your help.

    Mod

    Kenneth John Odle

    #30754
    Quote:
    First, the header image no longer spans the entire width of the header area.

    If you changed the theme’s width, you’ll need to create and upload a new header image. Generally, you can stretch it just a bit in both directions without a noticeable change in quality, so you may want to increase the height of your header image just afterward.

    Quote:
    Next, I noticed that my Twitter & Facebook icons disappeared from the top of the header.

    They’re not in the code. Check your top bar options and re-add them, if necessary.

    trailsnet

    #30755

    Thanks Kenneth. Everything is working just fine, now. Your patience and help have been greatly appreciated.

    Mod

    Kenneth John Odle

    #30756

    Perseverance pays off in the long run. Thank you for your willingness to experiment and learn.

    You have an interesting site. I’ve bookmarked your RSS feed, which is the highest praise I can give a site. Cheers!

    BTW: I read pretty fast, but even I’m a bit dazed by your slider. You might want to slow it down a bit.

    Marking thread as resolved. You can do this yourself as well.

    Cheers,

    Ken

    trailsnet

    #30757

    Thanks again Ken.

    Good suggestion. I slowed the slider down from 3000 milliseconds to 5000.

    I appreciate the bookmark of my RSS feed.

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.

Do NOT follow this link or you will be banned from the site!