menus partly disappearing

  • debbiej

    #4989

    Hi there!

    I hope I am posting this in the correct place, I do apologise if not. We have been working on a site for some months: http://www.familiesthroughadoption.ie

    The theme is graphene. All was working well until one of the team added a few new pages and a large part of the drop-down menus disappeared. The pages still exist, just the navigation is gone, both in the dashboard and online. There should be 2 more entire drop-down menus full of items.

    We have tried:

    Updating the theme and plugins

    Deactivating some plugins (could it be a conflict? I can retry this if so).

    Repairing the database

    Recreating the site on a test site by importing the db (I have a back-up)

    None of these worked.

    In the end we recreated the menu, which worked fine until we tried to add another few pages and it happened again.

    I must be missing something here, I presume! :-/ and would be so, so grateful for any help. I searched and searched and hope I am not duplicating an issue that has already been dealt with.

    Thank you!

    Debbie

    Mod

    Kenneth John Odle

    #30177
    Quote:
    added a few new pages and a large part of the drop-down menus disappeared.

    Try deactivating the multilevel navigation plugin.

    Moved to Support. Please post in the correct section next time.

    debbiej

    #30178

    Thanks for your help, Kenneth. I just tried that, and no joy.

    Mod

    Kenneth John Odle

    #30179

    Are you using a custom menu? If so, is it still intact?

    Admin

    Syahir Hakim

    #30180

    This might be due to server settings that limits the maximum amount of data you can send to the server at once. Basically, you’re trying to submit to the server more data than is allowed for, hence some of the menu items are truncated. See this topic on WordPress.org support forum for more info:

    http://wordpress.org/support/topic/wordpress-menu-problem?replies=11

    debbiej

    #30181

    Hi! thanks for the information. I’ll follow up with my host on the server limitations.

    Kenneth, I am not using a custom menu – just the graphene out of the box so to speak. Should I change this? Thanks again for any advice.

    We appreciate it!

    All the best

    Debbie

    Mod

    Kenneth John Odle

    #30182

    You can try a custom menu and see if that changes anything.

    A tutorial is here:

    http://blog.kjodle.net/2011/08/25/how-to-create-and-use-custom-menus-in-wordpress/

    But it sounds like you may have a server issue. If a custom menu doesn’t take care of the problem, you’ll need to contact your ISP and make them aware of the link Syahir provided.

    debbiej

    #30183

    Thanks so much for the advice! I’ve contacted my host, so we’ll see if that’s the problem.

    I will try a custom theme too.

    Will come back and report the solution – when I find it. 🙂

    debbiej

    #30184

    I mean custom menu! Trying that now. Thanks!

    debbiej

    #30185

    Just to explain the solution – it was nothing to do with graphene at all – but a memory limit on my server.

    These experts helped me in the end – it turned out I didn’t have suhosin on the server so the usual advice didn’t apply: http://wpquestions.com/question/showLoggedIn/id/4290

    Thanks for your help.

Viewing 10 posts - 1 through 10 (of 11 total)

You must be logged in to reply to this topic.

Do NOT follow this link or you will be banned from the site!