Menu Item not Linking to Posts in Category

  • emd2727

    #4860

    Here is the site I am working on: http://gslis.simmons.edu/blogs/scosaa/

    I am trying to set up my menu so that the “Events” and “News” links link to posts I have already added and categorized as either “Events” or “News.” When I created the menu, I chose the categories themselves, so it looks like:

    Home Custom

    Events Category

    News Category

    etc.

    Am I missing something; is there an extra step I need to take to get the categorized posts to show up?

    Thanks in advance!

    Admin

    Syahir Hakim

    #29547

    The “Events” and “News” links on the nav menu are links to pages, not to category archive pages. When you create the menu items, make sure you use “Categories” rather than “Pages”:

    TRDus.png

    See this tutorial by Ken for more details:

    http://blog.kjodle.net/2011/08/25/how-to-create-and-use-custom-menus-in-wordpress/

    emd2727

    #29548

    Thanks for the response! The problem is, though, that I did used “Categories” rather than “Pages,” and it’s still not working:

    I also double-checked and triple-checked to make sure I do have posts in those categories, and I do. Any ideas?

    Admin

    Syahir Hakim

    #29549

    What is your permalink setting?

    emd2727

    #29550

    It’s “Day and name,” one of the common settings. Is there something better?

    Admin

    Syahir Hakim

    #29551

    If you go WP Admin > Categories, and click on the “View” link under each category, what’s the URL it takes you to?

    You might want try setting a “Category base” in the permalink settings.

    emd2727

    #29552

    This is very embarrassing but I want to update with what I discovered as the problem just in case someone as dim as me looks at this forum in the future.

    I hadn’t given my Category menu items Title Attributes. Now that I have, everything is working.

    Thanks so much for your help, Syahir! Case closed.

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.