Leave a Reply section

  • Jimmiocean


    I am using the theme as website and don’t want the Leave a Reply box on my pages. How do I eliminate that on all the pages?


    Syahir Hakim


    If you don’t want the comments feature at all, you can disable the comments and pingbacks default settings for posts and pages. Just go to Settings > Discussion and uncheck Allow link notifications from other blogs (pingbacks and trackbacks.) and Allow people to post comments on new articles.

    However, this will only affect future posts and pages. Previous posts and pages will still have comments and pingbacks enabled by default. If you don’t have a lot of posts and pages, you can just use the Quick Edit function in Posts listing admin screen and uncheck the Allow Comments option.

    Otherwise, if you have a lot of posts and pages already, you can use CSS to hide the comment section.



    Hey, I tried this and have NO replies or posts. I even deleted the Hello World post and I can’t seem to get rid of the Leave a Reply box on all the pages.




    I’m not using a child theme cause I don’t even know what that is.



    If you just want to prevent the ‘Leave a Reply’ section showing up on all Pages on your site, but make sure it still shows up on single Posts, you could do the following:

    1) Open comments.php

    2) Round about line 34 or so, insert <?php if (is_single() && !is_page()) : ?>

    3) At the very end of the file insert <?php endif; ?>

    That worked for me.



    Awesome that worked Darren,

    It has to be the first line after

    <?php /* Lists all the comments for the current post */ ?>



    Kenneth John Odle


    However, if you edited the original file without creating a child theme, then that alteration will disappear the next time the theme is updated.

    You can turn off comments in Graphene Options >> General >> Comments. You can also change this on a post by post basis.


Viewing 8 posts - 1 through 8 (of 8 total)

  • You must be logged in to reply to this topic.