Keep HTML tags in excerpts doesn't work

  • Joey

    #48992

    Hi,

    as I try to fill in “Graphene Options —> Display –> Excerpt Display Options”: “Keep these HTML tags in excerpts” with any tag (I want links to be kept in excerpts, so I tried <a>, but also tried the given examples like <p>), it doesn’t work and I only get a message like “invalid value” (don’t know the exact english translation as my Graphene 2.1 is translated). Where is my mistake or how is this supposed to be filled in?

    I appreciate any help on this. Thank you!

    Admin

    Syahir Hakim

    #49019

    Thanks for the report. We’ve fixed the issue and will include it in the next theme update.

    Joey

    #49035

    Thank you, but can you give me some advice for a workaround until then? I really need links in the excerpts.

    Admin

    Syahir Hakim

    #49037

    Not really…there’s a few bugs that led to the issue, and fixing it involves modifying several of the theme’s files. The update won’t be long before it comes though; we’re expecting either this week or the next.

    Joey

    #49039

    Okay. Only I didn’t plan on updating because I modified the style.css (already have several childthemes running, as I use different colouring for subpages, and didn’t want to add another for the main theme). Or is it possible to use the old style.css with the theme update?

    Admin

    Syahir Hakim

    #49040

    That’s really not a good idea, since updates may include security fixes as well, on top of new features and enhancements. You can just swap the updated style.css with the modified style.css either, since some new features will require new styling as well.

    Why do you need different child themes for different subpages? You should only need a single child theme, and make all the modifications there.

    Joey

    #49042

    Because that’s beyond my knowledge of css modification. A multiple themes plugin manages which childtheme is used for certain pages. I didn’t find a way to do that without a plugin, and now I want to keep it this way, because it really works and looks fine.

    Seems I will need another plugin for the excerpts then.
    But thank you for replying!

    Joey

    #49048

    In case anyone else might ever wonder: I found a workaround for myself.
    If you want to keep HTML tags in excerpts you just have to use the WordPress function on the “Edit post page” at the bottom of the page: “Excerpt” (must be checked on top in the display options to show under the posting!). There you can insert the part of your posting that you want to show as the excerpt, and when you do it using HTML, it is kept on the output on your page.

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.