Return to Support

Is there a way to remove "website" Field from Comments

Home Forums Graphene WordPress theme Support Is there a way to remove "website" Field from Comments

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #9979
    ABCDiamond
    Participant

    I’ve looked at various options to get around spam, but I don’t like to use a captcha.

    I don’t want anyone putting a website in when they leave a comment. Most times it gets abused, and normal commenters do not have websites.

    It only gets spam websites showing, or people who put google etc in as they think they need to put something in.

    Is there a way to remove it totally.

    Thanks

    #45052
    Quote:
    I’ve looked at various options to get around spam, but I don’t like to use a captcha.

    If you don’t like the appearance of the captcha, there are other captcha options available.

    Quote:
    It only gets spam websites showing,

    Have you tried Akismet? It really cuts down on spam.

    Also, some anti-spam plugins add a hidden field which spambots can see and fill in (but which real people cannot) so that spambot comments get rejected automatically.

    #45053
    ABCDiamond
    Participant

    I have Akismet, and that works well for a lot of general spam, but the spammers are getting clever, and I think that the website URL put in the comment box box for websites may not be checked by aklismet.

    That is the one I want to cut out now. And I actually just want that field removed as it serves no purpose.

    I did find something yesterday, adding some code into the graphene themes functions.php. It removed the field, but when I tried it on a another of my sites, it didn’t do the same thing. That puzzled me. It would be great to have an option in the theme to have the website bit as an option.

    This was the code I used

    add_filter('comment_form_default_fields', 'url_filtered');
    function url_filtered($fields)
    {
    if(isset($fields['url']))
    unset($fields['url']);
    return $fields;
    }

    #45054
    ABCDiamond
    Participant

    Forget that …. After answering someone elses post about delayed viewing of changes, I realised my problem was the cache I also have activated.

    I checked my sites again just now, and they all work OK, with no website option on comments, now that my cache period has expired…

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.