I want to change "read more" button, but nothing works!

  • remike

    #6392

    Basically I want to show the excerpts and “read more” link on my home page, but I want to be in control of where the link appears. Sometimes it needs to be longer than 55 words. I’ve tried 3 workarounds that should work, but nothing changes! All in my child theme.

    Tried

    1:

    function custom_excerpt_length( $length ) {
    return 15;
    }
    add_filter( 'excerpt_length', 'custom_excerpt_length', 999 );

    No change

    2

    remove_filter( 'excerpt_more', 'graphene_auto_excerpt_more' );

    function custom_remove_excerpt_more( $more ) {
    return '';
    }
    add_filter( 'excerpt_more', 'custom_remove_excerpt_more', 999);

    No change

    3 Changed the setting for the homepage to display full posts, but I can’t afford to have a button (too much space). I used Prasanna’s method from this post: https://forum.graphene-theme.com/graphene-support/continue-reading-button to change the buttor into the link. Still no changes!!!

    What’s happening?

    PS I do refresh 5 times and try 2 different browsers.

    Mod

    Kenneth John Odle

    #34205
    Quote:
    Sometimes it needs to be longer than 55 words.

    WordPress sets a default excerpt length of 55 words. You can’t set a different amount for different posts.

    Instead, just use the “Custom Excerpt” in the post edit pane.

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.