How to remove "under construction" for individual pages?

  • uwebhofer

    #50046

    I just switched our theme to Graphene and suddenly a few pages show an additional “Under Construction” in the main navigation, like an additional description right underneath the page name. This is only visible in the primary navigation (not in footer navigation, not on page itself). There is no logic behind why some pages show it and other don’t (eg: only pages that are in dropdowns, etc.) and I tried moving the pages – it looks like the “Under Construction” stays with the page. There is no plugin that does this (I checked & deactivated all plugins). I checked the code and found that an additional span class seems to be in place:

    For example:
    Calendar <span class=”desc”>Under Construction</span>
    Calendar
    <span class=”desc”>Under Construction</span>

    This is the website: https://www.mitchellpta.org

    I’m assuming this is a setting by the Graphene, since I didn’t have it with the old theme. Can I switch this off globally? Or do I need to add a css to remove it? If yes, how?

    Admin

    Syahir Hakim

    #50049

    That is the “menu item description” feature in the Graphene theme. It is likely that WordPress is auto-populating the menu description with the post’s or page’s excerpt. For some reason, this happes to be “Under construction” in your site.

    To remove or change the description, go to Dashboard > Appearance > Menus. At the top right corner of the screen, click on the pulldown button labelled “Screen Options”, then tick the checkbox labelled “Description”. Each of your menu items will now have a “Description” field, which contains the text that you are referring to. You can delete or modify the text as necessary.

    uwebhofer

    #50050

    Thank you @SyahirHakim! That was it! Easy fix that took me hours to research. You are a WP rock star!

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.