Return to Support

How to remove the comment box from the page

Home Forums Graphene WordPress theme Support How to remove the comment box from the page

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #664
    Fino
    Member

    Hello,

    I like your theme very much. Very flexible. I loaded it for this site that I am working on: http://www.purposeandplancoaching.com. Before I updated to the newest WordPress Version, there was the possibility to remove the comment box from a page in the page options. So, some of my pages don’t have a comment box. The pages that I added after I changed, don’t have that button. How can I get rid of the comment box in those pages now?

    Thank you!

    Wendy

    #12613
    Syahir Hakim
    Keymaster

    It’s still there, but WordPress 3.1 hides it by default. In the Edit Post / Page screen, click on Screen Options in the top right corner of the page, and then tick Discussions.

    #12614

    I have the same problem – I’d like to take out everything on the page except the header and the page content and the widgets I put in. When I go to “screen options” for a Page, I only have Author, Comments, and Date options. No Discussions. I unchecked all three, but my page stil shows Leave a Reply/Submit Comment section, as well as another blank section below that.

    I’d appreciate any instructions that will take these out. And I’m a complete, somewhat intimidated, novice at changing code, so if I need to do anything there, please be very specific.

    Thanks much,

    Jennifer

    #12615
    erl
    Member

    Great theme. Thank you!

    I’ve tried the instructions you give here. Neither checking, nor unchecking ‘Discussions’ makes any difference at all.

    Also tried it with ‘Comments’, just to experiment. No difference at all.

    A working checkbox in the Graphene options would be nice.

    Thanks!

    #12616

    “A working checkbox in the Graphene options would be nice.” I agree. But until then …

    I was playing around (I love an undo command) and I went to Editor (under Appearance) and clicked on Comments over on the right Template list. Then I selected and deleted the all the code in the main box. (Copied it into a file and saved, just in case.) Then when I updated the site, lo and behold, the comments box was gone. Hurray!

    #12617
    webmaam
    Member

    Thanks so much ReissExecutive. I’ve been looking everywhere to find out how to remove that comment box. You are the man!!!!

    #12618
    Syahir Hakim
    Keymaster

    ReissExecutive, that’s not the recommended way to make changes, as your changes will be lost the next time you update the theme. It’s never a good idea to edit the theme’s core files directly.

    To disable comments, you first need to enable the Discussions options as per my instructions above, then uncheck the “Allow comments” and “Allow trackbacks and pingbacks on this page” option in the Discussion tab.

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.