How to remove excerpt thumbnails from posts

  • STO

    #2357

    My site is http://www.somethingtotallyoriginal.com

    I’ve been using a plugin called Post Teaser to display excerpts on the home page. I like this plugin because it makes the post excerpts look like this: http://somethingtotallyoriginal.com/wp-content/uploads/2011/11/goodexcerpt.png

    Here’s the problem; when I switched my sites theme to Graphene, all posts that had images in them started appearing like this: http://somethingtotallyoriginal.com/wp-content/uploads/2011/11/badpost.png

    I tried disabling the plugin and I’m fine with the way the excerpts look for regular posts — but the posts with embedded Soundcloud players do not show the player in the excerpt. This is a problem for me. I tried keeping the plugin on and removing all instances of the excerpt-thumb code in the styles.css file, but it didn’t actually do anything at all.

    So I need help accomplishing one of the following:

    A: Remove the excerpt thumbnail function entirely so I can use the Post Teaser plugin.

    B: Modify Graphene’s native excerpt display function so embedded Soundcloud players display. If this works, I will disable the plugin.

    Thanks for your time guys, I appreciate any help you give me.


    On a completely unrelated note, I just realized the footer is taking up the entire length of the page. It wasn’t doing that when I first installed the theme, so I probably messed something up when I was trying to fix this thumbnail problem on my own. Can anyone tell me how to get it to fit the way it’s supposed to?

    Mod

    Kenneth John Odle

    #19925

    A: Remove the excerpt thumbnail function entirely so I can use the Post Teaser plugin.

    You can always try adding something like this to your custom CSS:

    img.attachment-thumbnail,
    img.size-thumbnail,
    .wp-caption img {display:none;}

    I’m not sure of the exact code, but it’s something like that. Poke around a bit with Firebug; you’ll find it.

    B: Modify Graphene’s native excerpt display function so embedded Soundcloud players display. If this works, I will disable the plugin.

    Graphene has the ability to retain any sort of HTML tag in excerpts by going to Graphene Options >> Display >> Excerpts Display Options and entering whatever tags you would like to retain in the box labeled “Retain these HTML tags in excerpts”. You might try entering <object> in that box to see if your Soundcloud player displays in the excerpts.

    STO

    #19926

    Thanks for the reply Kenneth, your code for solution A worked.

    When I tried adding <object> to “Retain these HTML tags”, it displaced all the posts on the main page to the right by several pixels and still didn’t know the Soundcloud links. I’m wondering if the issue is stemming from the fact that the Soundcloud player is taller than the area of the post excerpt. Is there a way to make the excerpts bigger? Like right now it shows 2-3 lines — could I change that to 8 lines or so? I tried finding the code for this on my own, but I think I just suck at this.

    EDIT: The footer problem fixed itself when I updated to Graphene Ver 1.5.5.

    Thanks again for your time.

    Mod

    Kenneth John Odle

    #19927

    If I’m not mistaken, Soundcloud uses .swf files, which are difficult to control using conventional HTML and CSS methods. There have been a few discussions about controlling the placement of Soundcloud here in the last few weeks; they may have the information you need.

    As for excerpt length, it’s not the number of lines, but the number of words. You can try adding something like this to your child theme function file:

    function new_excerpt_length($length) {
    return 20;
    }
    add_filter('excerpt_length', 'new_excerpt_length');

    Change the 20 to the number of words you would like to include in excepts. Unfortunately, this may not fix your situation, since an <object> is not, technically, a word.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.