Hide Edit Post link in admin

  • raindance

    #1899

    When I’m logged in, there is that (edit post) link in the top right of the post. I want to hide that. It just bugs me visually as I’ve got my social media icons there now and it overlaps.

    I’ve added:

    .edit-post {

    display: none;

    }

    .post-edit-link {

    display: none;

    }

    to my child css, and it hides the words but not the ( )

    How can I get rid of the ( ) as well?

    Thanks in advance

    Anonymous

    #17630

    Add this to child css…

    .post-meta .edit-post, .post-meta .post-date-inline, .post-meta .print, .post-meta .email {
    display: none;
    margin-left: 5px;
    }

    NOTE: Check your other elements to make sure everything else you want is still there. I’m not sure what all pulls this property.

    raindance

    #17631

    Yes, that did it…thanks once again!

    Anonymous

    #17632

    You’re welcome.

    I’m thinking if you enable the “print” option or the “date” option within wordpress admin, that might not be visible after making this change.

    Haven’t played around with it enough. Just thought I should mention the possible conflict.

    raindance

    #17633

    Oh ya good point…ok thanks.

    Anonymous

    #17634

    I was just thinking on the above code. You might be able to just add

    .post-meta .edit-post {
    display: none;
    margin-left: 5px;
    }

    If this is accepted, it should still allow your “print, date, and email” to still show… IF you have those options selected in the admin.

    Anonymous

    #17635

    It might work, it might not 🙂

    raindance

    #17636

    I dont think I need those anyway…thanks for the fix 🙂

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.

Do NOT follow this link or you will be banned from the site!