Return to Support

Help with layout justification

Home Forums Graphene WordPress theme Support Help with layout justification

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #9130
    dbphoto1981
    Member

    Hi all, my site was working fine then for some reason I have gone back to it today and noticed the formatting on some of the pages is not correct: http://www.algarvebikeholidays.com/touring-bike/ these are in tables but have lost this on these pages, any ideas why? looks very messy as is?

    Any help would be great

    Thanks

    #42550
    Syahir Hakim
    Keymaster

    WordPress strips any HTML element in creating those short descriptions (otherwise known as “excerpt”). It’s probably better to create your own custom excerpt for each of those locations in the form of a proper summary of the location instead.

    #42551
    dbphoto1981
    Member

    Thanks Syahir, how do I go about creating a summary for that location for each page?

    Thanks

    #42552
    dbphoto1981
    Member

    Hi, does anyone know how to create a summary as Syahir has suggested? Thanks.

    #42553
    Syahir Hakim
    Keymaster

    In the Edit Page screen, click on the Screen Options on the top right, then tick the checkbox for Excerpt. There’ll be a new option on the page where you can insert your own custom excerpt.

    #42554
    dbphoto1981
    Member

    Thanks, just had a look and I dont have the ‘Excerpt’ option showing to check?

    #42555

    Excerpts for pages are not enabled by default in WordPress.

    Try adding this to your child theme’s functions file:

    <?php
    add_action('init', 'my_custom_init');
    function my_custom_init() {
    add_post_type_support( 'page', 'excerpt' );
    }
    ?>

    Change “my_custom_init” to something unique that won’t interfere with anything else in your functions file.

    #42556
    dbphoto1981
    Member

    Thanks Kenneth, what should I change “my_custom_init” to? sorry dont understand?

    Thanks.

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.