Help with header height

  • cuppy90

    #2903

    Hello, I need help with a header issue. I have created the child pages necessary to change the height of the header, however when I go into wordpress to add the taller image it still says my image should be 960 x 198 and forces me to crop it. When I view my site, I see the new space for the image, so the code is correct. How do I get around this and use the taller header image. Thanks so much.

    Josh

    #22535

    Hi Cathy,

    In addition to changing the css, you also need to alter a couple functions. Try inserting this into your child theme functions.php file:

    function graphene_custom_header_width(){
    return 960;
    }
    function graphene_custom_header_height(){
    return 198;
    }
    add_filter('graphene_header_image_width', 'graphene_custom_header_width');
    add_filter('graphene_header_image_height', 'graphene_custom_header_height');

    You can change the values to whatever you like. In your case, change the 198 to your new slider height.

    Cathy Espere

    #22536

    Thanks for the info and prompt response but I already did that. I changed the 198 to 250. My issue is when I am in wordpress and go to add the graphic. When I am here: http://navigatewithpurpose.com/wp-admin/themes.php?page=custom-header – it tell me: You can upload a custom header image to be shown at the top of your site instead of the default one. On the next screen you will be able to crop the image.

    Images of exactly 960 × 198 pixels will be used as-is.

    If you view the website – http://www.navigatewithpurpose.com – you will see the space I need is under the graphic that is up there now. WordPress will not allow me to put in the image without cropping it. Hope that makes sense.

    Josh

    #22537

    Can you paste your child theme functions.php file here?

    Remember to enclose the code with backticks, like this.

    Cathy Espere

    #22538
    <?php
    function graphene_custom_header_width(){
    return 960;
    }
    function graphene_custom_header_height(){
    return 250;
    }
    add_filter('graphene_header_image_width', 'graphene_custom_header_width');
    add_filter('graphene_header_image_height', 'graphene_custom_header_height');
    ?>

    Josh

    #22539

    Okay, we are going to do a workaround. I’m not really sure why this isn’t working for you.

    This is the URL of your current header image:

    http://navigatewithpurpose.com/wp-content/uploads/2012/01/cropped-viewer.jpg")

    So, let’s navigate to this folder using either FTP or your hosts control panel. What we need to do is overwrite the default image with our new one.

    So, open up your FTP program or log on to your hosts cpanel.

    Navigate to wp-content/uploads/2012/01/

    Then, name your NEW image cropped-viewer.jpg

    Lastly, overwrite your old photo with your newer one.

    This should bypass the graphene cropping option and display it as-is.

    Cathy Espere

    #22540

    Thank you so much Josh! I really appreciate your help. That worked perfectly. Now if I can figure out how to get rid of the top menu…………. perhaps I can pay you to help me with a few items?

    Josh

    #22541

    Of course. You may use my contact page so we don’t clutter up Syahir’s forum. I’ll go check out your top menu now.

    You can use my contact form here:

    http://www.joshlobe.com/contact-me/

    (Marking thread as resolved)

    Admin

    Syahir Hakim

    #22542

    You’re not actually using the child theme… perhaps you forgot to activate it?

    Josh

    #22543

    How did you know that, Syahir?

Viewing 10 posts - 1 through 10 (of 16 total)

You must be logged in to reply to this topic.