HELP ! I lost ALL my settings!

  • Flo

    #6190

    hello everybody !

    I really need help.

    I use the graphene theme with child theme. I spent a lot of time customizing the theme options, especially for colors.

    Tonight I lost ALL my settings!

    My only hope is that I made last week a manual backup by FTP of the files located in the root of my WordPress site.

    But I don’t know where is the file that contains the changes Graphene options.

    It is not in my sub-theme child (which contains only minor changes to the CSS), or in other theme files dating from the day I installed it.

    Could you tell me where to find the files modified to Graphene options in the files at the root of my site?

    Thank you in advance!

    (I’m French, so I use Google translator, thank you to explain simply and clearly)

    Prasanna SP

    #33607

    The changes you made in Graphene Options is saved in database. Not in any files under theme directory or root.

    Flo

    #33608

    Thanks you for your answer.

    Could you tell me exactly where in my database I can find the settings of graphene?

    And I have another problem:

    Following the changes yesterday, I tried to put the settings in place. But at the top on my site before the header, there are 4 lines that have appeared:

    Warning: Invalid argument Supplied for foreach () in / home / flobogo / public_html / wp-content / themes / graphene / includes / theme-utils.php on line 43

    Warning: implode () [function.implode]: Invalid arguments Passed in / home / flobogo / public_html / wp-content / themes / graphene / includes / theme-utils.php on line 47

    Warning: Invalid argument Supplied for foreach () in / home / flobogo / public_html / wp-content / themes / graphene / includes / theme-utils.php on line 43

    Warning: implode () [function.implode]: Invalid arguments Passed in / home / flobogo / public_html / wp-content / themes / graphene / includes / theme-utils.php on line 47

    How do I remove it?

    Prasanna SP

    #33609
    Quote:
    where in my database I can find the settings of graphene?

    It’s under graphene_settings in (wp)_options table.

    Quote:
    How do I remove it?

    If you haven’t edited core files, try replacing the theme with fresh copy from here – http://wordpress.org/extend/themes/graphene

    If it continues to trow warnings, set DEBUG mode to false in wp-config.php file.

    Flo

    #33610

    Thank you for your help, my problems are solved.

    – For options, I redid my settings because I don’t know if I edited the core or not.

    – About 4 warning lines, they disappeared when I handed over the color settings

    Just one last question, to avoid this problem again, could you confirm this: In the right column of Graphene general options, there is a tab “Import / Export theme options” -> is this a way to save the settings? How does this work on?

    Prasanna SP

    #33611
    Quote:
    How does this work on?

    It is meant for backing up (importing) Graphene Options. When something goes wrong, you can use that to restore the previous settings by exporting it.

    Flo

    #33612

    That’s what I thought.

    It’s a shame that I have not seen before, I would have avoided problems if I had made ​​a backup before changing anything!

    Hint: there should be a tooltip, such as “before any changes, make a backup”

    Thank you for all your information.

    Mod

    Kenneth John Odle

    #33613
    Quote:
    “before any changes, make a backup”

    This, however, applies to everything, not just Graphene.

    Flo

    #33614

    Of course, Kenneth, you’re right.

    But there it was a simple checkbox, and I did not realize that this would reset the settings!

    There should be a warning

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.