Return to Support

Header Menu Problems

Home Forums Graphene WordPress theme Support Header Menu Problems

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #2763
    gtadmin
    Member

    Hello Forum

    I am experiencing some trouble with the navigation menus, I never intended to have typical navigation across the top bar rather have my menus down the left column,(custom menus) however after creating a second menu for the sidebar it seems that all the pages now appear in the header bar regardless of the sidebar menu thay are attached to???

    The website was running without the header menu perfectly and although I have deleted all menus, recreated them etc etc I simply cannot remove the menu from the top.

    Im not a skilled developer by any means so any assistance would be appreciated.

    Web address is http://www.commercial-cr.com

    #21793

    Go to “Menus” and make sure you don’t have any specified in the “Theme Locations” area.

    #21794
    vinnyfx
    Member

    Hi Kenneth

    I do not have any menus selected under the theme specific options, Ive screenshot the menu pages in the admin dashboard just to clarify and in case you are able to see something obvious.

    http://commercial-cr.com/wordpress/wp-content/uploads/2011/12/menu1.png

    http://commercial-cr.com/wordpress/wp-content/uploads/2011/12/menu2.png

    Thanking you in advance for your eye on this, im sure its something silly I just cant see.

    #21795
    Josh
    Member

    Hmmm… I would try creating a third custom menu, but don’t add any pages or posts to it. Just leave it empty. Next, assign this empty custom menu to the header area under “Theme Locations”.

    How does that work?

    #21796

    Thanks for the screen shots; now I see clearly what the issue is: the theme automatically adds all top-level pages to the menu unless you use a custom menu. That’s what’s happening to you. Josh’s solution should work for you.

    An interesting problem…Thank you.

    #21797
    vinnyfx
    Member

    Josh, Ken,

    Thank you so much for the fix there, tbh I never would have realised that one without your kind intervention and swift support 🙂

    Now I just need to figure out how to shorten the page size slightly so to remove the white bar above the footer,

    Thanks again :))))))

    #21798
    Josh
    Member

    To get rid of the “break” at the bottom, try this:

    #footer {
    background: none repeat scroll 0 0 #000000;
    }

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.