Return to Support

header image upload problem

Home Forums Graphene WordPress theme Support header image upload problem

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #1158
    mhaseltine
    Member

    I get an error when I try to upload a custom header image. I don’t know if it’s my server or something else. As a workaround, I ftp’d the image and it’s thumb to the directory it was trying to upload to, but it wasn’t recognized on the custom header page so I could choose it.

    How do I accomplish this either way?

    Thanks,

    Michael

    #14748
    Syahir Hakim
    Keymaster

    What was the error message when you tried to upload the custom header image? Are you alo having the same problem when uploading to the media library?

    #14749
    mhaseltine
    Member

    Error message was: “The uploaded file could not be moved to /usr/local/4admin/apache/vhosts/sckc.ws/httpdocs/wordpress/wp-content/uploads.”

    I haven’t tried uploading to the media library.

    #14750
    Syahir Hakim
    Keymaster

    This is most likely to be the server’s issue, and there’s nothing I can do on my end to help you with it. Seems like PHP doesn’t have write permission to the uploads folder.

    If I were you, I would consider it to be a major issue, one that will have the highest priority to be fixed before I do anything else. Try talking to your hosting provider and see if they can help.

    #14751
    Syahir Hakim
    Keymaster

    This is most likely to be the server’s issue, and there’s nothing I can do on my end to help you with it. Seems like PHP doesn’t have write permission to the uploads folder.

    If I were you, I would consider it to be a major issue, one that will have the highest priority to be fixed before I do anything else. Try talking to your hosting provider and see if they can help.

    #14752
    mhaseltine
    Member

    I don’t have any problems ftping files to that folder with filezilla, but there’s no mechanism for choosing a file there to use as my header image.

    #14753
    Syahir Hakim
    Keymaster

    You can’t just simply FTP the image and then use it as the custom header image. That’s because WordPress needs to update the database to keep track which header image is uploaded for which themes, so that when you switch themes the same header image is not used for the new theme.

    Again, the main problem here is that WordPress is not able to write to the wp-content folder, which will cause a lot of WordPress functions to not work as they should. You should really try to fix that issue first before worrying about the header image.

    #14754
    mhaseltine
    Member

    OK, I got your point, and at least I understand why it wasn’t working the way I thought it might. However, it seems a small thing to add to the custom header page, in addition to the mechanism for uploading a file from my computer, one that would allow browsing and choosing a file already on the server. I wonder why it hasn’t been added. What if I simply overwrote one of the existing sample header images with my own?

    OK, so I’ll talk to the server admins. Will they need to know anything about how wordpress sends files in order to answer my question? Is it only a matter of directory permissions?

    Thanks again

    #14755
    Syahir Hakim
    Keymaster

    Yes sure, you can just replace one of the default header images with your own, but be advised that when you update the theme later on, the file will be replaced again with the theme’s own.

    Write permission problems are quite common in CMS packages, including WordPress, but it’s not the fault of the CMSs themselves. It’s usually a result of PHP being run as an Apache module and the appropriate folders don’t have global write permission (0777). Many hosts nowadays run PHP as separate, user-based processes so file and folder permissions are never a problem.

    You can try setting the folder permissions to 0777 yourself using FTP, and see if that fixes it first. Though be advised that this can lead to security vulnerability, especially if the site is on a shared hosting.

    #14756
    mhaseltine
    Member

    Update: They told me to set permissions to 777, but I tried 775 first, not really wanting the directory that public, and it worked.

Viewing 10 posts - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.