h1 heading missing from front page

  • Mango

    #6644

    Google and Bing report that the <h1> tag is missing from front page of site when using banner in header.

    Not sure how important this is, or how to fix it?

    Help appreciated.

    Mango.

    Mango

    #35146

    Can someone tell me how to add a <h1> tag to my Home Page if I have disabled it in the Header section so that I can use my own banner.

    Thanks

    Mango.

    Mod

    Kenneth John Odle

    #35147

    Use the Graphene header widget to add an <h1> element, and then use CSS to hide it with display:none;

    Keep in mind that some consider this to be black hat practice, and it may actually penalize your SEO. It’s best to have some kind of content on your front page.

    sutandaulay

    #35148

    Assalam Mualaikum, a little way I do on the front page of my site, you can change text_color in header.php into your stylesheet.css transparent and also change the text a transparent color for the title and the description, you need to remember the position of the header text in wp admin still shows, this silly little way from me but hopefully it can help, and apologize if there are shortcomings, Salam.

    Mango

    #35149

    Thanks for your reply Kenneth and Salam. Yes I have thought of doing similar things to what you are both suggesting but I live in fear of being penalized by the Search Engines.

    It’s a shame the theme doesn’t take care of it in some way. It sort of defeats the purpose of having a custom header.

    Thanks again for your suggestions.

    Mango.

    Prasanna SP

    #35150

    Enable header title and description to show over the header image. Then hide it using the below Custom CSS. The H1 title will still be in the source, but it can not be visible to people. Google Bot can still see the H1 tag on your homepage.

    .header_title, .header_desc {
    display: none !important;
    }

    Mango

    #35151

    Greetings Prasanna, thank you, that worked well when added to Custom CSS in Graphene Options.

    Interestingly I tried adding it instead to style.css on the Child Theme but that didn’t work for some reason.

    Thanks again,

    Mango

    Prasanna SP

    #35152
    Quote:
    Interestingly I tried adding it instead to style.css on the Child Theme but that didn’t work for some reason.

    If you’re using any caching plugin, you need to flush cache after adding the above code to child-theme style.css. You need to clear your browser cache as well. Hit Ctrl+F5 to clear browser cache.

    Mango

    #35153

    Hi Prasanna, yes you are correct. All good now, Thanks.

    Mango

    Prasanna SP

    #35154

    Marking thread as resolved. You can do this yourself as well.

Viewing 10 posts - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.