Gravatar showing on pages

  • Anonymous

    #138

    Syahir – thanks for producing such a great theme! A simple question: I notice that my gravatar appears on all my pages as if they were a post (though the category and author name don’t appear). I can’t see anyway to address this in the graphene options, and assume I need to edit the “loop” to remove the gravatar from the pages. Is this correct or am I missing something? Many thanks!

    Admin

    Syahir Hakim

    #11347

    There’s an option in the Graphene Display options page. Under Posts Display Options, make sure the Show post author's gravatar is unticked.

    oxbow

    #11348

    Thanks – I see this option, but by unticking it I remove the gravatar from not only the pages, but also the posts. I would like the gravatar to show in posts, but not in pages. It seems logical for the gravatar to have the same characteristics as the category and author name (ie they all appear in posts, but not in pages). I regard pages as “independent” in the sense that they do not have an author, category or gravatar associated with them. Does this make sense?

    Admin

    Syahir Hakim

    #11349

    I see…in that case no, there’s no option to disable the gravatar on pages, unless you modify the source code, which isn’t recommended cause then you’ll lose the changes when you update the theme.

    The easiest way I can think of right now is to use a child theme, and just use CSS to hide the gravatar in pages. I believe the following CSS codes would do:

    .page .post-meta p.post-author img.avatar{
    display:none;
    }

    I will remove the gravatar from pages in the next update.

    oxbow

    #11350

    Great, this does the trick. Thanks for the quick and clear replies – very much appreciated.

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.