Return to Support

Graphene theme with module "Google Maps Ready!" incompatibility

Home Forums Graphene WordPress theme Support Graphene theme with module "Google Maps Ready!" incompatibility

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #8790
    enigma86d
    Member

    Hello,

    Graphene doesn’t work with “Google Maps Ready!” plugin.

    The plugin loads the following CSS code

    .clearfix {
    float: none;
    clear: both;
    }

    Also graphene loads this code on index page

    <div id="content-main" class="clearfix grid_11">

    which is the main content column making it appear without sidebars on its side. The clearfix class is used in many divs so it breaks the whole layout.

    Does anybody have any idea how to go around this.

    PS. I don’t know if it is a Graphene bug or a wordpress/google maps ready bug.

    Marius

    #42164

    It’s not a bug, merely a compatibility issue.

    Let’s move this to Support, where someone will come up with an answer, I’m sure.

    #42165
    Luko
    Member

    That clearfix class is used in approximately 90% of themes. If plugin break layout because of clearfix class that would be a very bad plugin development :).

    Anyway, I tried to recreate the issue on my test site but with no avail, it looks normal:

    test

    Can you provide more details or even better a link to your problem?

    #42166
    enigma86d
    Member

    Hi Luko,

    Here is the website showing the error: http://www.tolbacueducatie.ro/

    I also made a image explaining it but I cannot uploads files here so I put it here: http://www.tolbacueducatie.ro/test.PNG

    The plugin looks pretty well done as in features and was last updated 3 weeks ago but from what you say I tend to believe the incompatibility is because of the plugin, not the theme.

    Thanks!

    Marius

    #42167
    Luko
    Member

    This is not plugin issue, well not through.

    If you put your sidebar to right, everything will work nice :). Sidebar on left works only if plugin is disabled. To be honest after 30 min looking I don’t know why. 🙁

    If I manage to solve this I will post solution here.

    Update:

    And the solution is to add this css in custom css on graphene options:

    .clearfix {
    clear: right;
    }

    This was really interesting 😉

    #42168
    enigma86d
    Member

    Cool, your fix works well.

    I still don’t understand this clearfix compatibility issue, but I’m glad it works. Thanks!

    Marius

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.