google+ rel="author"

  • hueskye

    #4787

    Hi;

    I am using graphene for quite a while, and I understand that sucha a perfect theme has to be really big to have so many options as this one.

    I have searched this support forum and found no answer for my question so far, and here’s my problem.

    I would like add rel=”author” value to google plus link which is displayed in top as an icon.

    Moreover, i would like this to appear both on index iste, and posts/pages. I don’t want to install any plugin for that. I know this requires simply finding proper php code line, but i can’t find it.

    So in general, the link to google+ profile (from button in header) should have this form:

    <a rel="author" href="myG+URL">

    could anybody help me with how i may do that?

    I dont want to add any string to the G+link, like

    G+URL/?relauthor

    Just i want to keep it simple with PHP

    Mod

    Kenneth John Odle

    #29184

    Moved to Support. Please be sure to post in the correct section.

    Also edited to keep bbPress from parsing code. Please remember to always place code between backticks.

    Moreover, i would like this to appear both on index iste, and posts/pages. I don’t want to install any plugin for that. I know this requires simply finding proper php code line, but i can’t find it.

    You should be able to achieve this via a custom function in a child theme. You really don’t want to edit the theme’s files, or you will lose any modifications you make in the next updgrade.

    Have you created a child theme yet?

    hueskye

    #29185

    i am sorry for the problems i caused.

    nope, i havent created any child theme yet

    Mod

    Kenneth John Odle

    #29186

    Posting in the right section ensures that people see your support request.

    Warnock applies.

    ronangelo

    #29187

    You can just post that info on the copyright section on the footer. That’s what I did to add google+ authorization.

    Appearance -> Graphene Option -> Footer Option

    add this.

    <a href="https://plus.google.com/########?rel=author">Author Name</a>

    Google will see this on every post/page and will confirm you as author.

    This works just fine, unless you have different authors posting on your site.

    sanujams

    #29188

    Adding to footer will not index the pages properly on Google servers. For example, the picture of your Google+ should appear along with your URL in Google search if it is properly indexed by Google.

    I use a Plug-in called, Google Plus Author Information in Search Result (GPAISR)Google Plus Author Information in Search Result (GPAISR) at http://wordpress.org/extend/plugins/google-author-information-in-search-results-wordpress-plugin/developers/

    This way it will work on Google servers.

    ronangelo

    #29189

    You can check here: http://www.google.com/webmasters/tools/richsnippets

    how a your urls show on google search results, whether your g+ image shows or not.

    Anonymous

    #29190

    If you just want to add by Author with G+ link at the end of posts, why do you need that plugin? Just use graphene_after_post_content action hook and add some HTML code. Graphene theme is so powerful to handle all these things.

    For example, I have this in my graphene_after_post_content action hook.

    by <a href="https://plus.google.com/105204781310950280530?rel=author">Prasanna SP</a>

    and widget logic – is_single(). So, it adds by Prasanna SP with Google+ link after each single post.

    You can see this in my blog. It is after Email Subscription form on every single post

    http://www.prasannasp.net/custom-recent-posts-widget/#text-46

    Anonymous

    #29191

    This topic is the closest thing I could find to post my question without starting new thread. This is probably a question for Prasanna

    I am having trouble when I post a link to my website on g+. It puts the site name, tag, but then duplicates the site again. I can’t figure out where its coming from? I copied both the inner and outer HTML for you to see from the posted link on g+.

    Outer HTML HippoTusk Blog – Camping BlogHippoTusk Blog Â»

    Inner HTML HippoTusk Blog – Camping BlogHippoTusk Blog Â»

    If anyone has an answer that would be great!

    Anonymous

    #29192

    @chrisp: WordPress SEO by Yoast plugin is causing this issue. To fix this, go to Graphene Options –> Display –> Miscellaneous Display Options –> Site title options and put #post-title in Custom content pages site title.

    If you are comfortable with child theme and php, you may try adding this code to your child theme’s functions.php file.

    <?php
    function my_remove_filter(){
    remove_filter( 'wp_title', 'graphene_title' );
    }
    add_action( 'init', 'my_remove_filter' );
    ?>

    This disables theme’s ability to change post titles. This is a much better solution.

    BTW, you have a nice colour scheme (except block button). I like that header image! 🙂

Viewing 10 posts - 1 through 10 (of 22 total)

You must be logged in to reply to this topic.

Do NOT follow this link or you will be banned from the site!