Getting rid of the Home Page Tab

  • qtmcdowell



    I am extremely knew to codex/web building and have no CSS or html experience, so any help would be greatly appreciated.

    I recently switched my website to a static home page ( and have tried to add custom css coding found in other posts on this forum to remove the original home page tab with no success.

    I have copied these codes into my custom css tab under Graphene Options with no success. Am I forgetting to format these in a special way?

    .home #post-2589 {display:none;}

    .post-205 .post-title, .post-title a {

    display: none;


    .home .page-title {

    display: none;




    Add this to Custom CSS.

    .home .type-page {
    display: none;



    I just added it, still not working…



    Are you sure you selected your home page as the front page because on my site it’s working fine.

    You could also make a menu using the options under Appearance -> Menus and select the pages you want.



    It shows up fine here. Did you clear your browser cache?


    Or, do you want to remove Home from menu?



    Yes, when I switched to the static front page option, I want to delete the “home” tab that originally came with the Graphene theme so that I can then create a new home page and select that as my static front page (as ChainKiller was suggesting).

    I also just re-checked my settings — reading option and the “static page” is set to choose the “home” page that I created myself (because obviously the “home” tab that originally comes with the theme doesn’t show up under pages).



    I also cleared my cache and made sure I had selected the “home” page I created as my static front page.

    Do I need to edit a template file to get rid of the automatic “home” tab that comes with the theme?



    Just create a custom menu from the menus page in your dashboard. You can select any page you want.




    I figured it out, I accidentally had duplicates of the “home” page on my custom menu. Thanks for the help.

Viewing 9 posts - 1 through 9 (of 9 total)

  • You must be logged in to reply to this topic.