Full width slider problem

  • Anonymous

    #2108

    Hi

    I have a full width slider on my homepage (960×230 px) http://filmbomben.dk

    But somehow the slider image is moved about 30 px to the left, leaving about 30 px of the next slider img visible…I want the slider img to be fully visible.

    I have double checked that my slider img has the right size (960px)

    Is there a good simple solution for this problem?

    Thanks for great theme and support forum

    iholdfast

    #18684

    I cant help you but I am curious how you managed to get a Full width slider?

    Thanks,

    Anonymous

    #18685

    Well it doesn’t work yet 🙂 But it is a combination of removing borders padding and margins (and shadow effects if you want to) and then adjusting the width to the full size of your website (in graphnes standard template it is 960 px). I use the one-colum theme so I adjusted theses classes in my child css:

    .one-column .full-sized.featured_slider #slider_root {

    width: 960px;

    }

    Anonymous

    #18686

    Also I just checked in firefox, that the slider is completely misplaced all the way to the right side….weird 🙁

    Anonymous

    #18687

    Try adding this to your CSS:

    .one-column .full-sized.featured_slider #slider_root {
    width: 960px;
    float: left;
    z-index: 100;
    }

    Anonymous

    #18688

    BTW… your image is only 930px as opposed to the sliders full width of 960px. This is why your image looks “funny” on the far right side of the slider.

    Anonymous

    #18689

    Thanks for the quick response

    The code totally worked for the firefox problem. cool 🙂

    But i still dont understand the other thing 🙁

    The image i upload and set as featured image is 960×230 – but somehow it gets croped in the procces.

    I tried inserting this code into function.php

    add_image_size( ‘featured-image’, 960, 230, true );

    But it still crops.

    Thanks again

    Anonymous

    #18690

    Here is the image the slider is pulling:

    background-image:url( http://filmbomben.dk/wp-content/uploads/2011/10/captain-america-logo4-930×230.jpg )

    See how it says `930×230′.

    Double check this file and report back.

    Anonymous

    #18700

    Wow you are quick

    Here is a link to the original image I am uploading and setting as featured image

    (http://filmbomben.dk/captain-america-logo.jpg)

    I double-checked my double check 🙂

    Thanks again

    Anonymous

    #18701

    You can leave the image as featured.

    But try this as well.

    Upload your 960px wide picture to a spot on your server. I use /wp-content/myimages/.

    Now, on the post/page you are using with the featured image… Look just below the edit panel and you will see “Graphene post/page specific options”.

    Under “Slider options” choose “custom url”. Then enter the url to your photo in the box below.

    This should prevent the “cropping” of your image. I think Syahir included a feature which auto crops certain images to prevent them from spilling over. Although, I tried different percentages and couldn’t see how it was going from 960px to 930px.

    Anyways, this should take care of the issue.

Viewing 10 posts - 1 through 10 (of 26 total)
  • You must be logged in to reply to this topic.
Do NOT follow this link or you will be banned from the site!