Front page excerpts now resolving paragraph or heading

  • rwpeck

    #7343

    I have posted a few articles where I needed a sub heading before launching into the main body. I placed the main title in the title bar, then, in the main body, I start with an explanation line that is assigned the “Heading 2” formatting (using the WordPress WYSIWYG editor), then clicked “Enter” do create a paragraph and drop down a line, then entered the text for the main body of the article. This formatting displays correctly when viewing the full article on its own page. However, I found that in the excerpt of the post listed on my main page, the sub heading formatting disappeared and so did the paragraph marker. The sub heading and body became one string of text on one line with no formatting. I went to Appearances / Graphene Options / Excerpts Display Options and unchecked the “Show Excerpts in Front Page” option, then opened the article for editing and used WP’s “Insert More Tag” instead. The article excerpt in the front page listing of posts now displays correctly.

    In other words, there is something in Graphene’s “Show Excerpts in Front Page” option that is removing paragraph markers and formatting from the post preview.

    By the way, I am currently building my first ever website and just discovered Graphene last night after hours and hours of looking at every theme known to man. I like the theme, but I love the customization capabilities. It looks like this is the theme we’re going to stick with, so I plan to visit your “donate” page later, then tell anyone who is thinking of building their own website that this is the theme to use.

    Mod

    Kenneth John Odle

    #37906
    Quote:
    In other words, there is something in Graphene’s “Show Excerpts in Front Page” option that is removing paragraph markers and formatting from the post preview.

    This is not a bug; this is default WordPress behavior. It automatically strips tags from excerpts, because … reason.

    Fortunately, Graphene has a way around this, which is why it’s so great. Go to Graphene Options >> Display Options >> Excerpt Display Options.

    In the box labeled ‘Retain these HTML tags in excerpts’ type:

    <p><h2>

    Click “Save options”, then empty your browser cache and your server cache (if you’re using one) and reload the front page. Should do the trick. If not, please let us know and include a link to the site in question.

    Moved to Support.

    rwpeck

    #37907

    Thank You! I was just now researching how to have a standard thumbnail attached to each new post when my search caused me to stumble across the very box you’re talking about. Because I’m clueless about HTML, when I first reviewed the Graphene options settings I totally ignored that box, kind of like how I ignore anything written in Chinese characters that I don’t understand. I’ll go insert the magic code now and quit bothering smart people with ignorant questions 🙂

    Admin

    Syahir Hakim

    #37908

    Has this issue been resolved? Please mark it as so if it is.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.