Fonts that were once working now are not.

  • grace

    #51710

    I asked this question elsewhere and got a response that suggests I go back to the theme developer. I will post there response below my question.
    _____________________________________

    The font selections on my of my site have suddenly stopped working, both in the posts (where I use Supreme Google webfonts to add the fonts to the tiny MCE editor) and in the headings and widget titles where they are added and controlled by Easy Google Fonts. The font control set up for the post titles is still working though.

    Using Inspect Element I can see that the code is still there to render the fonts correctly, but for some reason isn’t working.

    I can see the fonts in the classic block editor correctly on the dashboard, but they are no longer working when the post is live.

    I use Graphene theme. Have recently added JetPack Boost and use really simple ssl, advanced editor tools, Fastest cache and WP optimize on the site as well. All themes and plugins are up to date.

    I have tried going into the customizer and reloading all the font controls there. That did not work. I have also tried reinstalling Easy Google fonts, that did not work.

    I have tried turning off JetPack Boost but that does not resolve the issue. That is the only recent plugin change. Prior to that, the fonts were behaving normally.
    ______________________________________________
    This was the response I got:
    If you look here:
    https://pluginarchive.com/wordpress/fast-velocity-minify/v/2-4-4/2-4-1
    and search for ‘Google Fonts Request’
    you will see where there has been a new line of code added in the diff output:
    “+ $res[‘code’] = str_ireplace(‘font-style:normal;’, ‘font-display:block;font-style:normal;’, $res[‘code’]);”

    You have this same error in your theme:

    Which indicates that your theme is outdated, or is not accommodating for whatever this loop in the diff is trying to do.

    Then if you scroll down to line 779 of your page, you see you are using a different method to load Lato from Google fonts:
    view-source:https://randombitsoffascination.com/blog-2/

    There is a LOT going on with fonts on your site. Without commenting on that part, I think you could start by reaching out the theme developer or their support forum:
    ___________________________________
    Any direction or assistance in where to go from here would be greatly apprecited.

    Thanks!

    grace

    #51712

    I have since tried using Google Fonts Typography in place of Easy Google fonts and have regained some control of the fonts through that, though I still cannot impact the sidebar fonts with it.

    I have tried removing all font plug ins and controlling fonts with direct import of google fonts into the child them and font controls in the custom CSS. I have had some success with that, but since I really am not a coder this is a very difficult solution.

    grace

    #51713

    In addition, I tried the google font block from the Google font typography plug in and the font in the block did not change. You can see the post here: https://randombitsoffascination.com/2021/05/13/a-brief-history-of-blueancient-blue-pigments/

    The first block in the post is the font block and the font displayed is definitely not Parisienne as selected in the font block.

    Once again, any assistance you could provide would be appreciated.

Viewing 3 posts - 1 through 3 (of 3 total)

  • You must be logged in to reply to this topic.
Graphene Themes Forum