Return to Support

Firefox not rendering menu arrows properly

Home Forums Graphene WordPress theme Support Firefox not rendering menu arrows properly

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #8628
    Anonymous

    I love the Graphene theme! However, after I recently updated the theme version, Firefox v26.0 doesn’t show the drop down arrows in the menu any more on my website. Instead, Firefox now displays a strange character that looks like a square with “F4 31” text inside. I am using a child theme, so perhaps could there be an incompatibility between my original child theme and the new version of the Graphene parent theme?

    The problems sounds similar to this one but I’m not using Graphene Mobile.

    For example, see Training Events and About Us menus on my website: http://www.hadoopwizard.com

    Thank you in advance for any help or guidance on how to fix this on my site.

    Kudos for your awesome work on the Graphene theme!

    #41658

    Your child theme is set up incorrectly. You have:

    @import url("/wp-content/themes/graphene/style.css");

    Try changing that to

    @import url("../graphene/style.css");

    If that doesn’t work, try disabling plugins to rule out a plugin conflict. If not, try these steps:

    http://blog.kjodle.net/2013/07/04/troubleshoot-your-wordpress-blog/

    #41659
    AnneL
    Member

    I have same issue (tried in 2 browsers). No plug-ins. I just installed the theme 2 days ago. I made a child theme. When I followed the instructions for the child theme to the letter, it showed up on my themes page as “broken” because it didn’t have a stylesheet and I “needed to install the Graphene theme,” even though it’s installed. I tried several times. Then I simply took the graphene style sheet and copied it to the child directory and changed the header appropriately to indicate it was a child sheet. Code is therefore identical. Everything else looks and acts the same, but I still get the squares.

    What is the CSS for the arrows?

    #41661
    Quote:
    I simply took the graphene style sheet and copied it to the child directory and changed the header appropriately to indicate it was a child sheet. Code is therefore identical. Everything else looks and acts the same, but I still get the squares.

    This will break things. You should only include the code that you need to change in your child theme style sheet.

    #41662
    AnneL
    Member

    Yeah, I know. I’ve completely uninstalled and reinstalled the Graphene theme and recreated my child theme from scratch, and I keep getting this, despite having the parent theme installed:

    Broken Themes

    The following themes are installed but incomplete. Themes must have a stylesheet and a template.

    Name Description

    child-graphene The parent theme is missing. Please install the “Graphene Version: 1.9.2” parent theme.

    The ONLY way I can get the child theme to display properly is by making a duplicate. I successfully made a child of another theme with no problems, so the problem seems to be with Graphene and not with my coding, browsers, or WordPress. There are no plug-ins yet.

    #41663
    AnneL
    Member

    I took my successful child theme CSS, copied it to the right folder, and changed the name and this time it worked. The file looks exactly like the other 6 times I’ve tried. But at least it’s working now.

    #41664
    Luko
    Member

    Hy,

    Or you mess’t up @font-face for genericons in main theme style.css, or you have duplicate entry in child theme style.css.

    Anyway, you don’t have child theme installed as far as I see.

    Try to download the theme and replace style.css with original one.

    There must be this in main theme style.css before reset codes:

    @font-face {
    font-family: "Genericons";
    font-style: normal;
    font-weight: normal;
    src: url("fonts/genericons/genericons-regular-webfont.eot?#iefix") format("embedded-opentype"), url("fonts/genericons/genericons-regular-webfont.woff") format("woff"), url("fonts/genericons/genericons-regular-webfont.ttf") format("truetype"), url("fonts/genericons/genericons-regular-webfont.svg#genericonsregular") format("svg");
    }

    Or:

    In Firefox, go to Tools, Options, Content. In Fonts & Colors, go to Advanced. Check “allow pages to choose their own fonts….” That took care of it for me.

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.