Featured Image showing as blank

  • Jaifaime

    #5292

    Hello, awesome theme, really diggin it.

    My one issue is that images I set as the Featured Image for a page are showing as blank when I visit that page. Standard header images are displayed just fine.

    My procedure: I have a header image that displays fine (960×198). I decided I wanted to test having different header images on different pages. I opened my current header image in Photoshop, made desired visual changes to it (image is still 960×198). Uploaded the new image to the Media Library. Edited the desired page and set the new image as the Featured Image and saved the page. Browsed to the page, header image is empty.

    Custom header images per page is not mission critical, but is a neat feature and could be used to great effect with my site. Any help, hints, or clues would be greatly appreciated.

    Thank you for your attention,

    -Mark

    Mod

    Kenneth John Odle

    #31482

    Make sure the header image is .jpg or .gif.

    .png will not work.

    Jaifaime

    #31483
    Quote:
    Make sure the header image is .jpg or .gif.

    .png will not work.

    They are all .jpg

    (wow quick reply!)

    Jaifaime

    #31484

    If it helps, here is what the normal header looks like:

    good.jpg

    and here is what the Featured Image turns out looking like:

    bad.jpg

    Mod

    Kenneth John Odle

    #31485

    It could be a plugin conflict of some sort. Try temporarily disabling all of your plugins to see if that’s the issue:

    http://blog.kjodle.net/2012/06/15/disable-your-wordpress-plugins/

    Quote:
    (wow quick reply!)

    Sometimes….

    But your title was good and your description of your problem was thorough. It makes it easier to answer questions.

    If it’s not a plugin conflict, post a URL and we can take a closer look.

    Jaifaime

    #31486

    Sigh. Why did I not test for plugin compatibility. As soon as I read your reply I face-palmed.

    Looked at my list of plugins, “I bet it’s this one…” lo and behold the Lazy Load plugin was the culprit.

    Thanks for your help, very much appreciated!

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.