Featured image not showing in header

  • Adrianw

    #7559

    My site has featured images on several pages and posts.

    They have stopped being displayed in the header.

    They are definitely the correct size and they used to display OK.

    I’m not sure when this started because only a few pages/posts have the correct size featured image.

    I tried downgrading from 1.8.4 to 1.8.3 but that didn’t help.

    It’s possible there’s an incompatible plugin so I will start to eliminate them.

    Any other suggestions about how to identify the problem?

    Many thanks

    Adrian

    Adrianw

    #38624

    It turns out the problem was with the WordPress Jetpack plugin.

    Specifically, I had enabled the Photon option.

    The description of Photon says:

    Quote:
    Give your site a boost by loading images in posts from the WordPress.com content delivery network. We cache your images and serve them from our super-fast network, reducing the burden on your Web host with the click of a button.

    All the other images on the site seemed to display OK (but I haven’t tested every single page)

    The default header image displayed on every page even those where the featured image should have been shown.

    When I deactivate Photon, the featured images appear again in the header.

    Is this a known problem?

    I am on Jetpack 2.2.5 but I checked and the same problem occurs with 2.2.3 and 2.2.4

    Adrian

    Adrianw

    #38625

    ps For myself, and for now, this issue is resolved.

    However the incompatibility between Graphene and the Photon component of Jetpack concerns me because I would like to be able to benefit from the (claimed) performance improvements of Photon

    Is this something the Graphene developers could look into?

    Admin

    Syahir Hakim

    #38626

    Thanks for reporting. We’ll investigate the issue.

    Admin

    Syahir Hakim

    #38627

    OK, we’ve found the root cause of the issue and has implemented the fix, which will be included in the next update.

    Adrianw

    #38628

    That was quick.

    Many thanks.

    Adrian

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.