Excerpt of a page generates bad HTML for "Continue reading"

  • Anonymous

    #3072

    I don’t know yet if this is a problem with Graphene or the underlying WordPress 3.3.1.

    (same problem with Graphene 1.6 and 1.5.6)

    Example

    Go to http://compton.parish.hants.gov.uk/?s=city+walks

    The excerpt for the Walks page does not show the Continue reading button

    Generated html is

    <p><a title="Long &hellip; </p>
    <p><a class="more-link block-button" href="http://compton.parish.hants.gov.uk/sport-and-leisure/walks/">Continue reading &raquo;</a></p>

    Anonymous

    #23242

    I’ve figured out why this is happening:

    The automatically-generated excerpt finishes in the middle of an html tag.

    I am using the graphene option to retain the p, ul, li and a tags in excerpts.

    If I disable that option, then the “continue reading” button is displayed correctly in the auto-generated excerpt.

    But there’s another bug:

    If I insert a More tag in the source page (it’s a page, not a post), then the excerpt ends correctly at that point.

    But there is no “Continue Reading” link.

    Admin

    Syahir Hakim

    #23243

    I’ve modified the function so that it’ll try to balance the html tags in the excerpt. Will be available in the next update.

    Sent via Android using Tapatalk

    soapy

    #23244

    This is the same issue I’m having. If I add a more tag to a post, then the automatically generated “continue reading” button does not show up in my category archives (excerpt view).

    I figured the only work around is to add a function so that after, for example, 140 characters in my excerpts….the “continue reading” button is generated. Then, as long as I insert the more tag after 140 characters in my post….I’ll be able to see the continue reading button in the post in both the home page as well as when viewed as an excerpt (category archives, search results, etc).

    Make sense? Anyone have a better idea?

    Anonymous

    #23245

    This is what seems to be happening (apologies if I have made a mistake)

    The “Show More link for manual excerpts” setting is ignored.

    In the front page slider “View Full Post” is always displayed regardless of the setting of “Show More link for manual excerpts”

    Everywhere else, if you have inserted a More break manually, the “Continue Reading” or “View Full Post” link is never inserted at the end of an excerpt, regardless of the setting of “Show More link for manual excerpts”

    Admin

    Syahir Hakim

    #23246

    @Adrianw,

    “Manual excerpts” refer to the excerpts that you enter manually (see this post for more details), not the More tag that you entered in the editor.

    Anonymous

    #23247

    Thank you for the explanation about manual excerpts, which is very helpful.

    Can I make a suggestion:

    The text on the “Continue Reading” button should always say “Continue Reading” for automatically generated excerpts, and it should always say “Read Full Post” for manually generated posts.

    Currently it always says “Read Full Post” inside the slider and “Continue Reading” for all other excerpts.

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.

Do NOT follow this link or you will be banned from the site!