Error Message: In_Array ….

  • xenon2008

    #49405

    Hello Togehter!

    I have found a Error Message on my WP-Blog…
    Can please somebody help me?

    This Error is shown on my WordPress-Blog:
    Warning: in_array() expects parameter 2 to be array, null given in /home/.sites/864/site5290376/web/blog/wp-content/themes/graphene/inc/plugins.php on line 89

    Wordpress Version 4.9.5-DE-DE
    PHP Version:7.2
    Graphene Version:2.4

    Best Regards
    Xenon

    xenon2008

    #49406

    Sorry i am using PHP Version 7.1 NOT 7.2!

    Best Regards
    Xenon

    xenon2008

    #49407

    Me again…

    When i login in my WP Blog and open a Article, i can see the Message: “NOTICE: Please install and activate Yet Another Related Posts (YARPP) in order to use the Related Posts feature.”

    But if i logout i only see “Warning: in_array() expects parameter 2 to be array, null given in /home/.sites/864/site5290376/web/blog/wp-content/themes/graphene/inc/plugins.php on line 89 ”

    Why must i now install a Plugin, which is NOT UPDATED over a YEAR for the Feature Similar articles?

    Is there no other Solution?

    Best Regards
    Xenon

    xenon2008

    #49410

    Me again..

    I have now installed this Plugin, but the Message will be also displayed?
    Cane somebody help me please?

    Admin

    Syahir Hakim

    #49415

    The Related Posts feature is an optional Graphene theme integration with the YARPP plugin, similar like breadcrumbs using the Breadcrumbs NavXT plugin. Even though YARPP has not been updated for quite some time, it still remains as one of the best related posts plugin available.

    This feature is completely optional though. You don’t have to install the plugin if you don’t need the related posts feature. Your visitors will not see that notice either, as it’s only shown to admins to let you know that you have that option.

    I’ll investigate the other PHP warning message and get back to you soon.

    xenon2008

    #49417

    Helly Sayhir,

    Thanks for your Reply!

    Even if the plugin is not installed, but I still see Related Posts? Why ??

    And why i see the PHP Error Message even when i installed YARPP?

    In the past, the related posts also worked without YARPP

    Best Regards
    Xenon

    Admin

    Syahir Hakim

    #49418

    As long as the plugin is not installed and activated, the notice will appear to admins only. Your visitors will not see the notice, and you can safely ignore it.

    As for the PHP warning, it is unrelated to the notice. I’ll provide an update as soon as I have more information on this.

    xenon2008

    #49419

    Good Morning!

    Thank you Syaphir!

    And i have found out why i can see Releated Posts =)
    Because i have installed Jetpack and have enabled this Option!

    This is the reason why my Visitors can see Related Posts without having installed YARPP =)

    Sorry for tha =)

    Please keep me Up2Date…

    Mabul

    #49421

    When i login in my WP Blog and open a Article, i can see the Message: “NOTICE: Please install and activate Yet Another Related Posts (YARPP) in order to use the Related Posts feature.”

    But if i logout i only see “Warning: in_array() expects parameter 2 to be array, null given in /home/.sites/864/site5290376/web/blog/wp-content/themes/graphene/inc/plugins.php on line 89 ”

    Same for me here

    Admin

    Syahir Hakim

    #49423

    Thanks for the report guys. We’ll issue a fix shortly.

    Update: We have released version 2.4.1 which contains the fix to the above issue.

Viewing 10 posts - 1 through 10 (of 20 total)

You must be logged in to reply to this topic.