Drop down menu not working on internet explorer – please help!

  • thenortheasthub

    #6589

    I have just recently noticed the drop down menu on my site is not working and seems invisible?

    What can I do to fix this please?

    My site is http://thenortheasthub.com/blog/

    Any help really appreciated.

    Mod

    Kenneth John Odle

    #34969

    Which version of IE? IE6 is not supported, but this should work in IE7-IE9.

    If not, try disabling plugins to see if there is a plugin conflict. If disabling plugins makes the problem go away, then there is a plugin which is not compatible with whichever version of IE you are using.

    Moved to Support. Please post in the correct section next time.

    thenortheasthub

    #34970

    Hi Kenneth,

    I’m using IE9 and the drop down menu is invisible.

    Ill try disabling plugins now.

    Thanks

    thenortheasthub

    #34971

    Just a quick question.

    Once I have disabled a plugin are the effects immediately seen on my site (i.e. will i see the menu drop down work right away if it was that plugin causing the problem?) or do i have to clear my cookies / empty cache each time?

    Thanks again.

    Luko

    #34972

    Hy,

    Similar issue as seen here: https://forum.graphene-theme.com/graphene-support/ie9-shows-only-shadows-for-nav-subs

    You have position:relative on #header-menu-wrap. I think that some plugin inserted it, try disabling each plugin and see. You will see immediately if it’s plugin issue, but clearing cache is always good option 🙂

    Mod

    Kenneth John Odle

    #34973
    Quote:
    Once I have disabled a plugin are the effects immediately seen on my site

    Not necessarily. You will need to clear both your browser and server caches.

    thenortheasthub

    #34974

    Thank you Luko and Kenneth.

    I have resolved the problem by

    1. Going into the style.css of the graphene theme

    2. Finding the below code (starting on line 601), deleted the word ‘relative’, saved the file.

    /* Top level header menu, default state */

    #header-menu-wrap{

    position: relative;

    background: url(images/sprite_h.png) left -3px repeat-x #101010;

    z-index: 15;

    3. Cleared my cache

    4. Dropdown menu visible again on internet explorer 🙂

    Thanks for your help.

    Prasanna SP

    #34975

    ^ Don’t hack parent theme. Use a child theme instead.

    lisal

    #34976

    Please help! My drop down menus have suddenly disappeared but it doesn’t matter what browser you are in. It must have to do with something else and I cannot determine the problem. I have cleared out everything and disable all plugins. Any other suggestions? Did I accidentally select something somewhere? I have been building this site for a couple of months now and one of the reason we picked Graphene was because of the menu options.

    Thanks Lisa.

    Mod

    Kenneth John Odle

    #34977

    Lisa,

    Yours is a separate issue from this thread, since your site is affected in all browsers. Please feel free to start a new thread and be sure to include a link to your site. It is difficult to diagnose most issues without seeing them live.

Viewing 10 posts - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.