Displaying recent posts on homepage – homepage pane or widget?

  • ac11ca

    #5495

    My website: http://adriancamilleri.net/

    Question1:

    On the homepage, I want to show the last few posts (heading + some text) on the RIGHT SIDE of my webpage. What’s the best way to do this? Currently Ive got Homepage Panes activated, but the content goes to the bottom. How can I make it go to the right? I’ve also tried a wiget that shows the recent post with a sidebar, but the problem is that only the heading shows, not any content.

    Question 2:

    On the homepage, the “Read More” link on the summary of recent posts doesnt go anywhere. My post page is here: http://adriancamilleri.net/news/ I want it so that clicking on the heading of each post takes the user to a page showing that post in it’s entirety, but currently it takes them back to the homepage??

    Thanks for any help,

    Adrian

    Mod

    Kenneth John Odle

    #32077

    Moved to Support. Please post in the correct section next time.

    Question 2:

    This may be a plugin conflict of some sort. Try this:

    http://blog.kjodle.net/2012/06/15/disable-your-wordpress-plugins/

    Or it could be a permalinks issue.

    Question 1:

    Use the “Recent Posts” widget

    rocek

    #32078

    If you are interested, I have set up the recent topics and recent replies widgets side-by side in my homepage panes–see Here. I used some custom CSS that is posted elsewhere on this site, but I am happy to explain.

    Firebug is a great way to figure out how to design your CSS to make it do what you want.

    ac11ca

    #32079

    Sorry for posting in the wrong spot Kenneth.

    I am pretty sure I have a permalinks problem, since disabling my (3) plugins didnt fix the problem. There is a screenshot here showing where the permalink address should be… any ideas why it is missing and how to fix it?

    Thanks rocek – I will go with the recent posts widget for now and play around with Firebug

    Thanks,

    Adrian

    ac11ca

    #32080

    Right, found that in my settling/permalinks section the “custom” box was checked and nothing in it. Not sure how that happened, but all fixed now.

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.