Custom Search ended up in 404 randomly

  • sanuja.com

    #7511

    I am not sure if this is a Graphene related issue or I have to edit the functions.php in the child theme.

    I created a Google Custom search long time ago and stop using it because I moved my site to WP which came with a search function. I tried to implement it back and it only work when I typed my own name to the search (first name).

    I tried “Geology” and it goes to 404 page of the Graphene WP.

    What am I doing wrong? I followed the instructions on both Google and the WordPerss.

    You can see the widget on with CSE here: http://sanuja.com/blog/

    It seems like sometimes the Graphene theme is taking over all the requests from Google and turn it into their own and hence returning them in 404s.

    Thanks.

    sanuja.com

    #38508

    If you guys want to test it, try “geology” as a keyword. Google have many many pages on that from my site indexed and it works fine when I test the CSE outside of the site.

    Prasanna SP

    #38509

    Hmm.. It works fine here.

    m6U52Nj.png

    sanuja.com

    #38510

    Thanks Prasanna…

    I just fixed it. The issue was that the search conflicted with “?s=KEY_WORD_HERE” with the WP search which also uses ?s=

    I changed it to “q=KEY_WORD_HERE” and now it works fine.

    It was not Graphene, but rather an issue with WP search conflicting with Google.

    Thank you for answering my questions all the time.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.