Return to Support

Custom menus

Home Forums Graphene WordPress theme Support Custom menus

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #6127
    alexiarr
    Member

    Hello,

    I’m trying to use a custom menu with graphene theme. I have already create a child, but I didn’t perform any modification in the header.php or theme-menu.php.

    I create a custom menu with several items and followed the same steps in http://blog.kjodle.net/2011/08/25/how-to-create-and-use-custom-menus-in-wordpress/

    The problem is that when I assing a custom menu to Header Menu location, the menu in the site disappears (the one that is by default with the pages).

    I’ve tried also to look for solutions in the forum but without succes.

    I’m working on local, and I don’t have an online server yet.

    Wordpress version: 3.4.2–es_ES

    Graphene version: 1.8.2

    Thank you very much in advance.

    #33453
    alexiarr
    Member

    To give you more details, the menu disappear because now, the “ul” is empy when seeing the source code

    <div id="nav">
    <div id="header-menu-wrap" class="clearfix">
    <ul id="header-menu" class="menu clearfix grid_12"></ul>
    <div class="clear"></div>

    <div id="top_search" class="grid_4">
    <form id="searchform" class="searchform" method="get" action="http://localhost/wordpress">
    <p class="clearfix default_searchform">
    <input type="text" name="s" onblur="if (this.value == '') {this.value = 'Buscar';}" onfocus="if (this.value == 'Buscar') {this.value = '';}" value="Buscar" />
    <button type="submit"><span>Buscar</span></button>
    </p>
    </form> </div>

    </div>

    <div class="menu-bottom-shadow">&nbsp;</div>

    </div>

    #33454
    alexiarr
    Member

    I have found “partly” the problem. It is withing my functions.php

    I have added code only to use custom post, but it seems something was affecting menus… Now I just need to find what but I guess since this is not a graphene problem, this may not be the place to ask for. I will try in a wordpress forum.

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.