Return to Support

Comments on Selected Pages

Home Forums Graphene WordPress theme Support Comments on Selected Pages

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #9111
    trailsnet
    Member

    I would like to allow comments on certain Trailsnet pages. The site already allows comments for blog posts, but not for pages. Is it possible to allow comments for some pages but not others?

    #42791
    trailsnet
    Member

    Does anyone out there know if it’s possible to have comments on selected pages using the Graphene theme? Your help is appreciated.

    #42792
    #42793
    trailsnet
    Member

    Thanks Ken. I installed the No Page Comments plugin on Trailsnet, and it seems like a great addition, but…

    … With the plugin installed, as an administrator I’m able to add comments in edit mode (admin panel). But on the regular website pages viewed by the general public, such as the Trail Talk page, under the Leave a Reply area where users would generally leave comments, it has the (error?) message, “Blog token not found.” I’m not sure what that means, but it seems to be blocking people from leaving comments on that page.

    (It looks like they can reply to the comments that I’ve written, but not start their own comment thread.)

    #42794

    Well, there’s something I’ve never seen before.

    Googling “blog token not found”……

    ……..

    ….

    ……….

    ….

    Ah yes, try disabling and then re-enabling your Jetpack plugin.

    I can see people with similar problems here, here, and (probably) here, and this seems to be the solution.

    I know that seems like a weird solution, but it’s possible that plugin needs access to certain resources before Jetpack gets to them. Sometimes weird stuff like that happens.

    If that doesn’t fix it, let us know. In the meantime, I’m adding this to my “weird stuff that happens with Jetpack” file, which is getting bigger and bigger.

    And keep up the good work. We need more trails!

    You might also want to mention this to the plugin author on Github: https://github.com/sethta/no-page-comment/issues

    #42795
    trailsnet
    Member

    Thanks again, Ken. I’ll give that a try. I’ve just been searching for the disable option and discovered the Deactivate option. Is that the same thing? I’d hate to mess things up by doing the wrong thing.

    I seem to remember getting this message on my individual trail posts even before I installed the No Page Comment widget, so this may just be a JetPack issue.

    #42796

    Yes, deactivate should be the same thing.

    Your settings should still be there when you reactivate, however.

    As much as I like the functionality that JetPack provides, I gotta admit that things like this prevent me from adding it all my sites. It has some funky issues from time to time.

    #42797
    trailsnet
    Member

    Excellent, Ken!! That seems to have worked. The comments are now available on the pages where I need them.

    I appreciate your help & patience.

    #42798

    Cheers! Marking as resolved.

    #42799
    trailsnet
    Member

    Oops, I forgot to do that. Thanks Ken.

    #42800

    Dashboard – Pages -Quick edit Desired page – Check Allow comments box

    #42801
    trailsnet
    Member

    Thanks kbarandjelovac.

Viewing 12 posts - 1 through 12 (of 12 total)

You must be logged in to reply to this topic.