"Close comments after X days" hides existing comments…?

  • Unbeliever

    #7333

    I’m still new to WordPress and Graphene, but I think I’m doing pretty well. Graphene has certainly made customizing my group’s blog MUCH simpler than it could have been!

    One problem I’ve just noticed: I had enabled the “Close comments after X days” option, because I did not want new comments appearing on old posts.

    Instead, Graphene is taking away the comments link entirely, hiding even pre-existing comments after the specified period of time!

    This does not seem right; I had assumed it would merely hide the new comments form.

    Is there some existing way to accomplish what I want?

    I’m using a child theme, and don’t mind copying and tweaking a function or two, if I have to. I’ve even located what appears to be the offending line in theme-comments.php:

    function graphene_should_show_comments() {
    global $graphene_settings, $post;

    if ( $graphene_settings['comments_setting'] == 'disabled_completely' )
    return false;

    if ( $graphene_settings['comments_setting'] == 'disabled_pages' && get_post_type( $post->ID ) == 'page' )
    return false;

    if ( ! is_singular() && $graphene_settings['hide_post_commentcount'] )
    return false;

    if ( ! comments_open() && ! is_singular() )
    return false;

    return true;
    }

    I believe that last IF condition is what’s getting me. And there doesn’t APPEAR to be a graphene setting to change that behavior.

    But… I’d much rather flip a software switch (or install a plugin), than start hacking at the code willy-nilly myself.

    So… is there a better way to prevent new comments after a period of time, WITHOUT hiding the old ones?

    Thank you so much for any feedback you have…

    P.S.

    My WordPress, Graphene, and plugins are all completely up-to-date.

    And my site is http://CorvallisSecular.org if anyone is interested.

    Thanks again!

    Admin

    Syahir Hakim

    #37874

    OK, we’ll change this in the next update.

    Unbeliever

    #37875

    Wow! Thank you! I was just hoping for a workaround; it never occurred to me you’d change the baseline behavior.

    Until then, I’ll just leave comments open on all posts. It’s not like we’re exactly a BUSY blog yet.

    Thanks again for this! I’m glad I chose Graphene for my theme… 🙂

Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.
Do NOT follow this link or you will be banned from the site!