Change text from button 'Read more' into our

  • Maciej

    #38405
    Quote:
    its’ working now.

    Great. Big thanks for help !

    Hmm, it’s working with the ‘leave comment form’, but not with the ‘Read more’. Is the ‘read more’ correct text in english ver. of this theme? Im tryin to put ‘Read more’ => ‘Czytaj dalej’, and no effect.

    Prasanna SP

    #38406

    Yes, it is Read more. But it is used in homepage panes only.

    <?php
    function graphene_filter_gettext( $translated, $original, $domain ) {
    $strings = array(
    'Leave comment' => 'Skomentuj',
    'Read more' => 'Czytaj dalej',
    );
    if ( ! empty( $strings[$original] ) ) {
    $translations = &get_translations_for_domain( $domain );
    $translated = $translations->translate( $strings[$original] );
    }
    return $translated;
    }
    add_filter( 'gettext', 'graphene_filter_gettext', 10, 3 );

    ?>

    Maciej

    #38407

    And what it actually means ? :D. It’s not possible to change it than ?

    Maciej

    #38408
    Quote:
    And what it actually means ? :D. It’s not possible to change it than ?

    Cuz that code from above is not changing it.

    Prasanna SP

    #38409

    I mean, the “Read more” text is used in homepage panes only. Have you enabled the homepage panes? Can you post link to your site and tell which part do you want to translate?

    Maciej

    #38410

    Yep, I see, but actually ‘Leave comment’ is also only at homepage, like ‘read more’. But since it’s all workin well with ‘Leave a comment’, for some reason nothing happend when i want to change ‘Read More’.

    I cant post link to my site, cuz i’m working on it offline throught XAMPP application.

    Prasanna SP

    #38411

    You could change the language to English and check what’s the exact English word for it.

    Maciej

    #38412

    where can i change the language of Graphene Theme ? :>

    Prasanna SP

    #38413

    You can’t change theme’s language. You have to change WordPress language in wp-config.php

    Change

    define ('WPLANG', 'pl_PL');

    to

    define ('WPLANG', '');

    Maciej

    #38414

    Its ‘Read the rest of this entry’.

    Anyway, changing it in functions.php still don’t resolve the problem. nothing happend.

    Strange

    Maybe problem is, that i used that button ‘read the rest of this entry’ as a tag ‘more’ while makin new post. I don’t rly know.

Viewing 10 posts - 11 through 20 (of 20 total)

You must be logged in to reply to this topic.

Do NOT follow this link or you will be banned from the site!