Caching

  • sharpvideo

    #9478

    I’m using neo and I’m not a power user. I’m looking at my website on two different devices:

    1. A laptop, and

    2. A Kindle set to force a mobile display.

    I’m using a plugin that has casheing (Wordfence.)

    Just when I think I have everything working on my Kindle mobile display, the desktop shows the mobile version. Then I get the desktop to work properly and the mobile display (requesting a mobile version) shows the desktop version.

    Would the casheing cause this?

    I can record a screen capture, if this would help.

    The site is: rackinghorselane.com. It would seem to me if I were on a mobile device that all the pages would be mobile. Most of the “Learn More” pages are correct, but then one comes up as a desktop??? I have turned off casheing for now, but I’m not convinced that is the problem.

    sharpvideo

    #43694

    Since the first post, I have tried various “fixes.” I have disabled the Word Fence Cache and gone to the W3 total Cache and upgraded to the trial Any Mobile Theme Pro Switcher. Still have times when the wrong presentation is given. Clearing the Cache gets it working properly again. Is it standard practice to have a “choose you view” link on each page? It would seem like we would not need that.

    Admin

    Syahir Hakim

    #43695

    Caching is indeed the cause of the issue, specifically page caching. This bypasses the standard WordPress processing and directly serve saved (i.e. “cached”) page to the visitors to improve performance.

    With Any Mobile Theme Switcher Pro and W3 Total Cache, these two steps should be taken:

    1. Apply Rejected cookies setting.

    2. Enable High and Low User Agent Groups in WP Admin > Performance > User Agent Groups.

    That should solve the issue caused by W3TC page caching.

    sharpvideo

    #43696

    I’ve waited to see if I can figure this out by myself. No Luck. I had already done the “rejected cookies” setting. After your post, I Enabled High and Low Users Agent Groups.

    The home page ends up being the desktop view. By ends up, I mean that if I empty all caches, it works properly. Then some time later the home page (rackinghorselane.com) ends up showing the desktop view while the other pages correctly show the mobile view.

    The “don’t cache front page ” box is not checked in Total Cache (why wouldn’t you want the speed advantage on that page?)

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.

Do NOT follow this link or you will be banned from the site!