can't upload the image

  • syarifniskala

    #37

    Assalamu’alaikum wr wb.

    Hi Khairul, thank for the great theme.

    I found error when tried to upload images. Here the message:

    “suicide.jpg” has failed to upload due to an error

    Unable to create directory /home/syarifni/domains/pendidikanseks.info/public_html/wordpress/wp-content/uploads/2010/09. Is its parent directory writable by the server?

    Would you mind helping me.

    Thanks, wassalam.

    Syarif Niskala

    Admin

    Syahir Hakim

    #10808

    Waalaikumussalam, and hi Syarif.

    The problem you are describing is not related to nor caused by the Graphene theme. In most cases, it is due to the file permission setting in your server. You should really answer what the error message says: is the parent directory writable by the server?

    In your case, I believe you need to change the wp-content/uploads/2010 folder’s permission to 777. There’s a lot of tutorial on how to do this. See this WordPress codex page on file permission for starters.

    syarifniskala

    #10809

    Thanks for quick respond.

    I am sure that the permission is 777.

    When I installed WP, the default directory was like: home/syarifni/domains/pendidikanseks.info/public_html/wordpress/wp-content/uploads/2010/09,

    For hosting purpose, the directory has changed to : home/syarifni/domains/pendidikanseks.info/public_html/wp-content/uploads/2010/09

    Is it the factor? And how to solve the problem.

    Thanks, wassalam.

    Syarif Niskala

    Admin

    Syahir Hakim

    #10810

    Hurm..yes, this could very well be the reason. Try going to the Settings > General admin page and check both the site address and wordpress address.

    syarifniskala

    #10811

    Dearest Syahir,

    Directory setting on General, already changed to: http://pendidikanseks.info both (instead of http://pendidikanseks.infowordpress). But still didn’t work.

    Admin

    Syahir Hakim

    #10812

    Try to manually verify that the folder uploads, 2010, and 09 exist on the server . If they are, try changing the permission of all of these folders to 777.

    syarifniskala

    #10813

    Dear Syahir,

    I tried with manually make directory: public_html/wordpress/wp-content/uploads/2010/09 ( directory installed ublic_html/wp-content/uploads/2010/09 still exist). When upload, the image store in public_html/wordpress/wp-content/uploads/2010/09 and no error message.

    But, the image didn’t show on the post (while editing) and neither in front of page.

    I think there is a problem in placement image process of theme.

    Oh, all permission already set to 777

    Thanks – Syarif Niskala

    Admin

    Syahir Hakim

    #10814

    hurm..seems like there’s a conflict between where your wordpress install stores the uploaded files and where it thinks those files reside. It must be something to do with the file path settings somewhere, or maybe in the database.

    What directory does the whole of wordpress files currently reside in, public_html or public_html/wordpress/?

    Also, you might want to check the Settings > Media admin page, and try modify the settings for Store uploads in this folder and Full URL path to files.

    syarifniskala

    #10815

    Thanks,

    Whole of wordpress files are in public_html.

    Yes. It works! I modified the setting for Store uploads in this folder.

    Thanks a lot.

    Wassalamu’alaikum war wab.

    Syarif Niskala

    Admin

    Syahir Hakim

    #10816

    Finally!

    Glad it works out for you 🙂

Viewing 10 posts - 1 through 10 (of 11 total)

You must be logged in to reply to this topic.