Cannot access wordpress admin-Probably not a Graphene Issue but thought, you have great support

  • msllama

    #3535

    I am unable to gain access to my admin

    http://www.llamasofsocal.org/WordPress/

    The item I was trying to change was the Site URL

    changed it in the wordpress admin then the trouble started.

    Followed instructions on wordpress.org

    http://codex.wordpress.org/Changing_The_Site_URL

    When the site quit working I tried to back out all of the changes but without success.

    It is showing the error:

    Warning: require(./WordPress/wp-blog-header.php) [function.require]: failed to open stream: No such file or directory in /hermes/web08/b2206/eh.llamasof/WordPress/index.php on line 17

    Fatal error: require() [function.require]: Failed opening required ‘./WordPress/wp-blog-header.php’ (include_path=’.:/usr/local/lib/php-5.2.17/lib/php’) in /hermes/web08/b2206/eh.llamasof/WordPress/index.php on line 17

    Any assistance would be appreciated.

    Thank you,

    Tee

    #24732

    I’m not php savvy seems like you have errors in your index.php file. Did you back up your files before you made any changes to the core files? Also are you using the Graphene theme?

    I did something similar to this before, the only way I fixed it was using an FTP to replace the file I edited with a backup.

    msllama

    #24733

    Thank you I think you are correct. And yes I am using the Graphene Theme, I love it! and no I do not have back up for that file, I was just wrapping this up. I am converting a large frontpage website for a club I belong to to a WordPress site, this was the last change I had then was going to back up….Lesson learned.

    Tee

    #24734

    You can copy & paste the codes from here and save it in notepad then save the files as index.php, upload it via FTP to your theme folder.

    http://code.google.com/p/graphene/source/browse/branches/1.6

    Let me know if that works.

    Prasanna SP

    #24735

    Change the sire url back in your WP database using phpMyAdmin. That will fix the issue. Then change your site address carefully.

    Using phpMyAdmin:

    phpMyAdmin –> WP database –> browse _options table. Then edit siteurl field and enter the correct address.

    Prasanna SP

    #24736

    If you want to move your /wordpress directory to root, you need to follow these steps – http://codex.wordpress.org/Moving_WordPress#Moving_WordPress_Within_Your_Site

    (Not the above one you’ve given.)

    Apparently, you can call files from /wordpress on root by changing site url in WP settings and copying index.php and .htaccess file from the /wordpress directory to the root. If you are going to do that, you need to change require('./wp-blog-header.php'); to require('./wordpress/wp-blog-header.php'); in the copied index.php (in root).

    For this, follow these instructions – http://codex.wordpress.org/Giving_WordPress_Its_Own_Directory#Using_a_pre-existing_subdirectory_install

    msllama

    #24737

    Thank you all, site is now live again, will back up first! then follow the new instructions. Thank you

    msllama

    #24738

    you need to change require(‘./wp-blog-header.php’); to require(‘./wordpress/wp-blog-header.php’); in the copied index.php (in root).

    >>in your response above there is a reference to “wordpress”. In my case would the text be wordpress or WordPress to be consistant with the url?

    http://llamasofsocal.org/WordPress/

    Thank you, hope to get it right this time.

    Mod

    Kenneth John Odle

    #24739

    In general, URL’s are case-insensitive. (This is not always the case on some sites that provide free hosting, however.)

    Prasanna SP

    #24740

    require('./wordpress/wp-blog-header.php'); is okay. But, better is to be in the right side. So, if your wordpress directory is named WordPress, then replace require('./wp-blog-header.php'); with require('./WordPress/wp-blog-header.php');

Viewing 10 posts - 1 through 10 (of 11 total)

You must be logged in to reply to this topic.