Blog page doesn´t show posts

  • Yvonne


    Hello there,

    at first thank you for that elegant and useful WordPress-theme and all the support.

    I have a huge problem with activating my blog posts inside my website with a static frontpage.

    I know that this problem was already posted by many others here in this forum, but none of the solutions seem to solve my problem.

    What I already did and tried:

    – created a page named Blog (without any texts or a featured image)

    – created a few posts

    – set: Settings –> Reading –> Front page displays –> A static page / Front page: ‘home’ and Posts page: Blog

    – changed the permalinks-settings a few times

    – set the Front Page Options to ‘–Disabled–‘

    – created a custom menu for that blog to show in my left sidebar

    – add blog page to my main menu

    – renamed the blog


    I hope you can help me.

    Thanks a lot in advance.


    (My wordpress-installation and the theme both are updated.)



    How many posts you’ve published? Try disabling all plugins to check if it is a plugin conflict.

    Also, your feed returns 404.



    Until now I only published 3 posts with some text for testing.

    I`ll disable the plugins in the next days and let you know what happened.

    I hope that these aren´t the problem because I really need my two plugins 😉





    Hallo again,

    I figured out that the plugin ‘qtranslate’ causes the problem, somehow.

    When I deactivated it then my blog is working quite well.

    Do you have any advices how to fix that problem because I need this plugin to run my website in different languages? Maybe another similar plugin which works with Graphene in a better way?

    What do you mean with “Also, your feed returns 404.”?

    Thanks again for your support,



    Syahir Hakim


    Hi Yvonne,

    I would recommend using [url=]WPML[/url] for your multilingual needs. In my experience, it is by far the most complete and versatile multilingual solution for WordPress, though it is not a free plugin. I am using it myself on a few sites that need to be multilingual.

Viewing 5 posts - 1 through 5 (of 5 total)

  • You must be logged in to reply to this topic.