bbPress Log-In Issues with Theme

  • AReaHerps

    #3882

    I recently switched to the Graphene theme (which I must say is quite awesome!!!), mainly because I wanted something that I could integrate a forum into without creating a separate site or subdomain. Plus this was the only theme that looked great right out of the box.

    With that said, if this is a bbPress issue and not a theme issue, I will certainly seek help in a different location. I am horrible with code but with simple instruction, I could navigate my way around it.

    I uploaded the bbPress plugin, created a page, and promptly began placing the shortcode in the widget areas for loggin in and registering. The default log-in was already filled out for me and I clicked the ‘Log-In’ button and when I refreshed my screen it took me to the home page. I reopened my WP log-in screen and when I logged in, it took me to my home screen again, not my WP admin panel. Am I doing something wrong? I want to be able to integrate everything in this theme without having to leave and log-in to an entirely different site. Please help. Thanks

    Admin

    Syahir Hakim

    #26442

    It seems that the bbPress login widget sets a wrong redirect URL. Looking at the HTML code of the login form, there’s this line:

    <input type="hidden" value="http://localhost/theme-graphene/site/theme-graphene/site/forums/forum/graphene-support/" name="redirect_to">

    Obviously the URL in the value attribute isn’t supposed to be like that. It’s supposed to be like this:

    <input type="hidden" value="http://localhost/theme-graphene/site/forums/forum/graphene-support/" name="redirect_to">

    The same problem occurs when using the TwentyEleven theme as well, so it’s likely not a theme issue. Are you using WordPress Multisite or just the normal WordPress install?

    You might also want to check out this topic in the bbPress support forum:

    http://bbpress.org/forums/topic/help-link-log-out-error-after-bbpress-installed

    Update: I’ve just tried using the latest development version of the bbPress plugin, and this issue seems to have been fixed. You can expect it to be fixed in its upcoming 2.1 release.

    AReaHerps

    #26443

    I appreciate the response. I will certainly try this before starting over. I really do love the theme and would prefer to use this rather than the TwentyTen theme. I will post an update later. Thanks

    AReaHerps

    #26444

    @Syahir Hakim – I went ahead and simply started my site all over. I would love for you to see how great your template looks. It appears that bbPress is acting MUCH better now! There are still many things to figure out with bbPress and the customization I can do to it through Graphene. I may just have to hire you to figure it out! 😀 Thanks again.

    http://www.centralcoastherps.com

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.