404 Redirect not working

  • Hank_Handsome

    #6153

    Hi

    My 404 redirect doesn’t seem to be working on my dev site.

    Can anyone suggest where I could be going wrong?

    The site is here:

    http://testing.walkingplaces.co.uk

    A bad URL is here

    http://testing.walkingplaces.co.uk/walk55

    Thanks

    Hank

    Prasanna SP

    #33511

    All of your posts returns 404. Example, http://testing.walkingplaces.co.uk/walk-54-at-out-witts-ends/ It seems your site is missing the .htaccess file. Make sure you have it on root directory. A typical .htaccess created by WordPress will be like this,

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress

    Hank_Handsome

    #33512

    Yes, sorry about that – I have been playing with .htaccess as I thought that may be the issue – somehow I’d deleted it and not restored it.

    I have recreated default file by saving changes in Permalinks options.

    The link you mention now works, but the bad link I mention in the OP still doesn’t.

    Thanks for looking at this and hope you can now help 🙂

    Prasanna SP

    #33513

    Did you edit 404.php? I see the HTML source instead of the 404 page on http://testing.walkingplaces.co.uk/walk55

    Hank_Handsome

    #33514

    No I haven’t edited 404.php

    I have just set up a new site, on a new database, for the client to begin data entry and that is showing the same symptoms

    It also shows the HTML code rather than the expected page display

    Hank_Handsome

    #33515

    I now have this site live and the 404 redirect, although it is working to an extent, is not formatting properly.

    As you can see from this:

    http://www.theramblingbadgers.walkingplaces.co.uk/walks.htm

    I have the .htaccess provided by WordPress, checked it and its the same as the one mentioned above.

    I have not edited 404.php

    Any ideas where I’m going wrong?

    Prasanna SP

    #33516

    What permalink structure you have in permalink settings? Do you have .htm there?

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.