404 page is not Graphene's 404!

  • Kreachure

    #3898

    Hi, my blog isn’t using Graphene’s (excellent) 404 error page anymore. It simply goes to a custom 404 from my host (Bluehost), but with the same URL as the error URL. I think they changed something when I asked them to fix a redirect error I made when messing with my .htaccess file. Does anyone know where I should fix this? I appreciate the help even if it ends up not being Graphene-related… 🙂

    Prasanna SP

    #26496

    Can you post the content of your .htaccess file here. (Use pastebin.com if it has so many lines). I bet, a misconfiguration(?) in .htaccess file is causing the issue.

    Apparently, try resetting your permalink settings.

    Kreachure

    #26497

    Hi Prasanna. My permalinks are on default right now. The htaccess for my wordpress install (myblog.net/blog) is empty:

    # BEGIN WordPress

    # END WordPress

    This is the file I messed up, and had to call Bluehost for.

    However, the level above my install (public_html folder) has another htaccess, with this:

    # Use PHP5 Single php.ini as default
    AddHandler application/x-httpd-php5s .php

    and this level also has several shtml files, 401, 403, and 404.shtml. I have no idea if this has to do with my problem or not.

    Sorry if what I’m explaining is confusing to you; I have no idea what elements and folders are normal for any wordpress page, and what is exclusive to Bluehost’s system.

    Prasanna SP

    #26498

    Okay, go to WP-Admin –> Settings –> Permalinks Settings (better is to with post name structure) and save permalink settings. That should create an .htaccess file in your wordpress install.

    If not, create an .htaccess file with,

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

    Kreachure

    #26499

    Ah, changing the permalink setting did it! I didn’t think it would be that simple… Apparently the 404 works fine with any permalink setting except the default, but I don’t care about going back to the default anyways. 😉 Thank you very much, Prasanna!

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.

Do NOT follow this link or you will be banned from the site!